Задать вопрос
20 февраля, 06:38

Напишите на паскале. Задание: Написать программу, определяющую, можно ли треугольник со сторонами a, b, c поместить внутри круга радиусом

R

+3
Ответы (1)
  1. 20 февраля, 06:58
    0
    Var a, b, c, r, s, p: real;

    begin

    write ('длины сторон треугольника a, b, c через пробел: ') ;

    readln (a, b, c) ;

    write ('радиус круга r: ') ; readln (r) ;

    p: = (a+b+c) / 2;

    s:=sqrt (p * (p-a) * (p-b) * (p-c)) ;

    if r> = (a*b*c) / (4*s) then writeln ('можно поместить')

    else writeln ('нельзя поместить') ;

    end.

    длины сторон треугольника a, b, c через пробел: 3 4 5

    радиус круга r: 2.49

    нельзя поместить

    длины сторон треугольника a, b, c через пробел: 3 4 5

    радиус круга r: 2.5

    можно поместить
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Напишите на паскале. Задание: Написать программу, определяющую, можно ли треугольник со сторонами a, b, c поместить внутри круга радиусом R ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Помогите информатика 8 класс Задача 1. Составить программу определяющую длину фамилии и имени. Задача 2. Даны два слова. Составить программу определяющую произведение данных слов. Задача 3.
Ответы (1)
Информатика "Программирование разветвляющихся алгоритмов" 1. Написать программу, определяющую, является ли произвольное число X четным. 2. Написать программу, определяющую, является ли целое число T делителем целого числа X. 3.
Ответы (1)
1). Дан миссив из n целых чисел. Напишите программу определяющую сколько в массиве четных чисел, 2). Дан массив из n целых чисел. Напишите программу определяющую каких элементов в точке больше положительных или отрицательных
Ответы (1)
1. Напишите программу, определяющую сумму S=1+2+3+4 ... + 99 2. Напишите программу, определяющую произведение P=1*2*3*4 ... * 10 На Паскаль За ранее благодарна
Ответы (1)
Составить программу, определяющую, является ли данное утверждение истинным: Двузначное число А начинается на 3 Составить программу, определяющую, является ли данное утверждение истинным: Ровно одно из чисел А и В не превышает 100
Ответы (1)