Задать вопрос
28 апреля, 19:28

Дан целочисленный массив из 5 элементов возвести в квадрат отрицательные элементы

+3
Ответы (2)
  1. 28 апреля, 22:38
    0
    Program square_negative;

    var

    a: array[1 ... 5] of integer;

    i: integer;

    begin

    writeln ('Ввод массива: ') ;

    for i : = 1 to 5 do

    begin

    write ('a[', i, '] = ') ;

    readln (a[i]) ;

    if a[i] < 0 then

    a[i] : = a[i] * a[i];

    end;

    writeln ('Вывод изменённого массива: ') ;

    for i : = 1 to 5 do

    write (a[i], ' ') ;

    end.
  2. 28 апреля, 22:46
    0
    Какой ЯП?

    Pascal?

    var a:

    array[1 ... 5] of integer;

    i:integer;

    begin

    writeln ('Введите 5 чисел') ;

    for i:=1 to 5 do

    readln (a[i]) ;

    for i:=1 to 5 do

    if a[i]<0

    then writeln (sqr (a[i])) ;

    readln;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Дан целочисленный массив из 5 элементов возвести в квадрат отрицательные элементы ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Хотя бы 3-4 задачи! 1) Дан одномерный целочисленный массив размерностью N. Найдите количество элементов, которые кратны 3 (5). 2) Дан одномерный целочисленный массив А, состоящий из N элементов. Найти сумму всех четных элементов массива.
Ответы (1)
дан массив из семи элементов написать программу подсчитывающую среднее второго и предпоследнего элементов массива дан целочисленный массив из 10 элементов написать программу находящую сумму элементов массива красных 3 ил 5 дан целочисленный массив
Ответы (1)
1) Дан массив из n элементов. Найти номер наименьшего элемента массива. 2) Дан массив из n элементов. Упорядочить массив по возрастанию. 3) Дан массив из n элементов. Упорядочить массив по убыванию.
Ответы (1)
Помогите решить задачи на паскаль. 1) Дан массив случайных чисел (количество элементов вводите с клавиатуры). Найти произведение всех элементов массива. 2) Дан массив случайных чисел (количество элементов вводите с клавиатуры).
Ответы (1)
1.) Вывести на экран одномерный целочисленный массив, состоящий из 10 целых чисел из диапазона [-100; 100] 2.) Задан одномерный целочисленный массив, состоящий из 7 случайных чисел.
Ответы (1)