Задать вопрос
13 февраля, 11:36

Напишите программу на Паскале, которая выводит все простые числа в диапазоне от K до N (2 ≤ K ≤ N ≤ 100000), оканчивающиеся на цифру 3.

Примеры

входные данные

2 30

выходные данные

3 13 23

+2
Ответы (1)
  1. 13 февраля, 15:13
    0
    Var

    k, n, x, d: integer;

    begin

    read (k, n) ;

    for x : = k to n do

    if x mod 10 = 3 then

    begin

    d : = 2;

    while x mod d 0 do d : = d + 1;

    if x = d then write (x,' ') ;

    end;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Напишите программу на Паскале, которая выводит все простые числа в диапазоне от K до N (2 ≤ K ≤ N ≤ 100000), оканчивающиеся на цифру 3. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Помогите решить! 1))) Вводятся 4 числа: a, b, c и d. Выведите все числа на отрезке от a до b, дающие остаток c при делении на d Входные данные 1 4 1 2 выходные данные 1 3 Входные данный 1 5 0 4 выходные данные 4 2))) Выведите все числа на отрезке от
Ответы (1)
Уровень B. Задача M. Две одинаковые цифры рядом Напишите программу, которая определяет, верно ли, что введённое число содержит две одинаковых цифры, стоящие рядом (как, например, 221). Входные данные Входная строка содержит одно натуральное число.
Ответы (1)
Напишите программу, которая выводит все простые числа в диапазоне от K до N (2 ≤ K ≤ N ≤ 100000), оканчивающиеся на цифру 3. Входные данные: Входная строка содержит два натуральных числа, разделённые пробелом, K и N (2 ≤ K ≤ N ≤ 100000).
Ответы (1)
Напишите программу, которая выводит все простые числа Софи Жермен (такие, что для числа p число 2 p + 1 тоже простое) в диапазоне от K до N (2 ≤ K ≤ N ≤ 100000).
Ответы (1)
В PascalABC Напишите программу, которая выводит все простые числа в диапазоне от K до N (2 ≤ K ≤ N ≤ 100000), у которых первая и последняя цифры десятичной записи одинаковые.
Ответы (1)