Задать вопрос
18 июля, 11:26

Найти дискриминант квадратного уравнения, если коофициент вводится с клавиатуры

+4
Ответы (1)
  1. 18 июля, 15:01
    0
    Var a, b, c, e, f: integer;

    d, x1, x2: real;

    begin

    write ('Введите коэффициент x^2: ') ;

    readln (a) ;

    write ('Введите коэффициент x: ') ;

    readln (b) ;

    write ('Введите свободный член: ') ;

    readln (c) ;

    d:=b*b-4*a*c;

    if (d>=0) then

    begin

    x1: = (-b+sqrt (d)) / (2*a) ;

    x2: = (-b+sqrt (d)) / (2*a) ;

    write ('Уравнение имеет 2 корня: ') ;

    writeln;

    writeln ('Первый корень: ', x1:4:2) ;

    writeln ('Второй корень: ', x2:4:2) ;

    end

    else

    writeln ('Дискриминант < 0') ;

    readln;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Найти дискриминант квадратного уравнения, если коофициент вводится с клавиатуры ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Помогите решить 3. С клавиатуры вводится четырехзначное число. Получить число, равное произведению его цифр. 4. С клавиатуры вводится натуральное число п. Узнайте в нем количество цифр. 5. С клавиатуры вводится натуральное число п.
Ответы (1)
Напишите задачи в Паскале задача1 {вводится целое число n от [0 ... 200]. Затеи вводится n целых чисел от [0 ... 1000000] Вывести на экран их произведение.} задача2 {вводится целое число n от [0 ... 200]. Затеи вводится n целых чисел от [0 ...
Ответы (2)
Напишите программу на паскале) 1. С клавиатуры вводится 3-хзначное число. Определить какая из его цифр больше. 2. С клавиатуры вводится 3-хзначное число. Определить является ли произведение его цифр 3-хзначным числом. 3.
Ответы (1)
Найти: а) сумму всех целых чисел от 100 до 500; б) сумму всех целых чисел от a до 500 (значение a вводится с клавиатуры; a 500) ; в) сумму всех целых чисел от - 10 до b (значение b вводится с клавиатуры; b - 10) ;
Ответы (1)
1. Массив и 4 целых чисел вводится с клавиатуры. Найти и вывести произведение элементов массива. 2. Массив из 6 отрицательных и положительных целых чисел вводится в области описания констант. Найти сумму положительных элементов массива. 3.
Ответы (1)