Задать вопрос
30 декабря, 03:58

Создать программу.

Которая при вводе возраста человека от 1 до 100 лет выводит на экран этот возраст с последующим словом "год" или "года" или "лет"

+2
Ответы (1)
  1. 30 декабря, 06:12
    0
    Var i, j: integer;

    begin

    readln (i) ;

    j:=i mod 10;

    if j=1 then writeln (i,' год')

    else if (j=2) or (j=3) or (j=4)

    then writeln (i,' года')

    else writeln (i,' лет')

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Создать программу. Которая при вводе возраста человека от 1 до 100 лет выводит на экран этот возраст с последующим словом "год" или "года" ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Помогите написать программу в python Уровень C. Напишите программу, которая получает возраст человека (целое число, не превышающее 120) и выводит этот возраст со словом "год", "года" или "лет". Например, "21 год", "22 года", "25 лет".
Ответы (2)
1. Написать программу, которая запрашивает возраст человека, а затем, если возраст меньше 14 лет выводит на экран: "У вас пока нет паспорта", если возраст больше 14 лет выводит на экран: "У вас уже есть паспорт", а если возраст равен 14 годам,
Ответы (1)
Напишите программу, которая в зависимости от введенного возраста добавляет слова "год", "года" или "лет". Например, при вводе возраста 1, программа сообщает "1 год", при числе 2 - "2 года", при числе 125 - "125 лет".
Ответы (1)
Помогите составить программу) Введите исходные данные: Возраст Коли: 12 Возраст Миши: 17 Средний возраст: 14.5 лет Возраст Колт отличается от среднего возраста на: - 2.5 лет Возраст Миши отличается от среднего возраста на: 2.5 лет
Ответы (1)
напишите программу, которая вводит возраст человека (целое число, не превышающее 120) и выводит этот возраст со словом "год", "года" или "лет". например: 21 год, 22 года, 25 лет
Ответы (1)