Задать вопрос
24 мая, 03:28

Напишите программу, которая в зависимости от введенного возраста добавляет слова "год", "года" или "лет". Например, при вводе возраста 1, программа сообщает "1 год", при числе 2 - "2 года", при числе 125 - "125 лет".

+4
Ответы (1)
  1. 24 мая, 05:56
    0
    Var age:integer;

    begin

    readln (age) ;

    if ((age mod 100 > = 10) and (age mod 100 < = 19)) then writeln (age, ' лет')

    else if (age mod 10 = 1) then writeln (age, ' год')

    else if ((age mod 10 > = 2) and (age mod 10 < = 4)) then writeln (age, ' года')

    else writeln (age, ' лет') ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Напишите программу, которая в зависимости от введенного возраста добавляет слова "год", "года" или "лет". Например, при вводе возраста 1, ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1) Напишите программу, которая строит "квадрат" из знаков '*' заданного размера. Используйте процедуру. 2) Напишите программу, которая выводит в столбик цифры введённого числа, начиная с последней. Используйте процедуру.
Ответы (1)
10. Составить программу, осуществляющую ввод числовых переменных. При вводе положительного числа вывести информацию: "Число больше ноля", при вводе отрицательного числа - "Число меньше ноля", при вводе ноля - "Вы ввели ноль".
Ответы (1)
Составить программу, осуществляющую ввод числовых переменных. При вводе положительного числа вывести информацию: "Число больше ноля", при вводе отрицательного числа - "Число меньше ноля", при вводе ноля - "Вы ввели ноль".
Ответы (1)
Требовалось написать программу, которая для введённого натурального числа n выводит общее количество его различных делителей, включая 1 и n.
Ответы (1)
1. Составьте программу, которая определяет, является ли сумма цифр введенного целого трехзначного числа четным числом. 2. Составьте программу, которая определяет, является ли последняя цифра введенного целого числа нечетным числом. 8 класс.
Ответы (1)