Задать вопрос
6 сентября, 20:14

Напишите программу: винипух съедает 100 грамм варенья в первый день, во второй день ещё 100 грамм, в третий день 200 грамм, В каждый последующий день он съедает кол-во варенья равное сумме количества варенья в 2 прошедших дня. За сколько дней он съест К грамм варенья?

Паскаль 10 класс

+2
Ответы (1)
  1. 6 сентября, 23:55
    0
    Var k, k1, k2, kn, n, s:integer;

    begin

    write ('k = ') ;

    readln (k) ;

    k1:=100;

    k2:=100;

    s:=k1+k2;

    if k<=k1 then n:=1 else n:=2;

    while s
    begin

    n:=n+1;

    kn:=k1+k2;

    s:=s+kn;

    k1:=k2;

    k2:=kn;

    end;

    writeln ('n = ', n) ;

    end.

    Пример:

    k = 1100

    n = 5
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Напишите программу: винипух съедает 100 грамм варенья в первый день, во второй день ещё 100 грамм, в третий день 200 грамм, В каждый ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Ввести слово и число раз (Ввод; паскаль, 3). Вывести это слово так: паскаль паскаль паскаль паскаль паскаль паскаль
Ответы (1)
Составьте программу в Паскаль с помощью while. У Малыша К банок варенья. В первый день Карлсон съел одну банку, в каждый последующий день съедая в 1,5 раза больше, чем в предыдущий. Через сколько дней варенье кончится?
Ответы (1)
Помгите! Программа Паскаль Вопрос 1. Функция служебного слова Var. Вопрос 2. С какими числами можно работать в программе Паскаль? Вопрос 3. Оператор ввода. Как он записывается в Паскаль? Вопрос 4. Функция служебного слова Const. Вопрос 5.
Ответы (1)
Создать программу которую с клавиатуры вводится количество секунд, прошедших с начало суток, определить кол-во полных часов и мин. Прошедших сначало суток
Ответы (2)
поставьте знаки арифметических операций в каждой схеме. А) скорость? время=путь б) путь? время=скорость в) масса 1 батона? количество батонов=общ. масса г) кол. батонов? кол. буханок=общ. кол. д) кол. конфет в 1 коробке? кол. коробок = общ. кол.
Ответы (1)