Задать вопрос
12 сентября, 20:42

Создать программу которую с клавиатуры вводится количество секунд, прошедших с начало суток, определить кол-во полных часов и мин. Прошедших сначало суток

+3
Ответы (2)
  1. 12 сентября, 22:39
    0
    Var s, m, h:integer;

    begin

    readln (s) ;

    h:=s div 3600;

    m: = (s-h*3600) div 60;

    if m=60 then

    begin;

    inc (h) ;

    m:=0;

    end;

    writeln (h,':', m) ;

    end.
  2. 13 сентября, 00:31
    0
    В часе 60 минут и 60*60=3600 секунд. Следовательно нужно проверять сколько раз входит в число секунд ваши интервалы:

    var sec:integer;

    begin

    readln (sec) ;

    writeln ('proshlo ', sec div 3600, ' polnyh chasov ili ', sec div 60, ' polyh minut') ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Создать программу которую с клавиатуры вводится количество секунд, прошедших с начало суток, определить кол-во полных часов и мин. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Напишите программу на паскале) 1. С клавиатуры вводится 3-хзначное число. Определить какая из его цифр больше. 2. С клавиатуры вводится 3-хзначное число. Определить является ли произведение его цифр 3-хзначным числом. 3.
Ответы (1)
Помогите решить 3. С клавиатуры вводится четырехзначное число. Получить число, равное произведению его цифр. 4. С клавиатуры вводится натуральное число п. Узнайте в нем количество цифр. 5. С клавиатуры вводится натуральное число п.
Ответы (1)
Напишите задачи в Паскале задача1 {вводится целое число n от [0 ... 200]. Затеи вводится n целых чисел от [0 ... 1000000] Вывести на экран их произведение.} задача2 {вводится целое число n от [0 ... 200]. Затеи вводится n целых чисел от [0 ...
Ответы (2)
Написать программу для pascal abc С начала суток прошло N секунд (целое). Найти кол-во полных часов, прошедших с начала суток.
Ответы (1)
1) Сначала суток прошло n секунд, определить: сколько полных часов прошло с начала суток, сколько полных минут прошло с начала текущего часа, сколько полных секунд прошло сначала текущей минуты.
Ответы (1)