Задать вопрос
5 августа, 13:18

Составьте программу в Паскаль с помощью while. У Малыша К банок варенья. В первый день Карлсон съел одну банку, в каждый последующий день съедая в 1,5 раза больше, чем в предыдущий. Через сколько дней варенье кончится?

+3
Ответы (1)
  1. 5 августа, 15:46
    0
    Var K, den, s_el: real;

    Begin

    Writeln ('Введите K банок') ;

    readln (K) ;

    s_el:=1;

    K:=K - s_el;

    den:=1;

    While (K>0) do

    Begin

    s_el: = s_el * 1.5;

    K:=K - s_el;

    den:=den+1;

    end;

    Writeln ('Варенье кончится через ', den, ' дней') ;

    readln () ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Составьте программу в Паскаль с помощью while. У Малыша К банок варенья. В первый день Карлсон съел одну банку, в каждый последующий день ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Напишите программу: винипух съедает 100 грамм варенья в первый день, во второй день ещё 100 грамм, в третий день 200 грамм, В каждый последующий день он съедает кол-во варенья равное сумме количества варенья в 2 прошедших дня.
Ответы (1)
Ввести слово и число раз (Ввод; паскаль, 3). Вывести это слово так: паскаль паскаль паскаль паскаль паскаль паскаль
Ответы (1)
Составить циклический алгоритм! Спортсмен первый день пробежал 10 км. Каждый последующий день он пробегал на 10% больше чем предыдущий. Через сколько дней он будет пробегать больше 15 км в день.
Ответы (1)
Внимательно прочитайте предложение. Если приглядеться, то буквы несколько подряд идущих слов образуют термины, связанные с информатикой и компьютерами. 1. Обманывать Малыша было глупо, сказал Карлсон правду: "Это я съел все варенье! 2.
Ответы (1)
В первый день строительства Колизея работал один рабочий и уложил 100 камней. Каждый последующий день рабочих становилось больше на один и каждый приносил на 1 камень больше, чем предыдущий.
Ответы (1)