Задать вопрос
16 марта, 05:33

Найти корень уровне ни ax^2+bx+c=0

+5
Ответы (1)
  1. 16 марта, 08:22
    0
    Uses crt;

    var

    d, a, b, c, x1, x2: real;

    begin

    writeln ('Введите a, b, c') ;

    readln (a, b, c) ;

    d : = b * b - 4 * a * c;

    if d > 0 then

    begin

    x1 : = (-b + sqrt (d)) / (2 * a) ;

    x2 : = (-b - sqrt (d)) / (2 * a) ;

    writeln ('x1 = ', x1:2:2) ;

    writeln ('x2 = ', x2:2:2) ;

    end

    else if d = 0 then

    begin

    x1 : = - b / (2 * a) ;

    writeln ('x = ', x1:2:2) ;

    end

    else

    writeln ('Нет действительных корней') ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Найти корень уровне ни ax^2+bx+c=0 ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
11. Каталог файлов является эффективным инструментом, так как А) является широко признанным форматом Б) показывает все папки на каждом уровне В) имеет четкие навигационные пути, обеспечивающие полное представление на каждом уровне папки Г) позволяет
Ответы (1)
Используя подпрограмму (корень из n + n) решить: (корень из 5 + 5/2) + (корень из 3+3/2) + (корень из 7+7/2)
Ответы (1)
Помогите решить задачи по информатике (на уровне знаний 7 класса) с помощю PascalABC 1. Дано 2 числа найти модуль разности этих чисел увеличенный в 5 раз. 2. Дано 4 значное число поменять местами 1 и 2 цифру местами 3.
Ответы (1)
Помогите решить задачу (на уровне 7 класса) в pascalABC Дано 2 числа найти модуль разности чисел увеличенный в 5 раз
Ответы (1)
составить программу на паскаль: Имеются сведения о 40-и регионах страны: название региона и информация об уровне безработицы в регионе. Определите три наиболее благополучных и три неблагополучных района
Ответы (1)