Задать вопрос
7 июня, 17:30

Составьте программу, вычисляющую, сколько раз в строке X встречается слово Y. Строку X и слово Y введите с клавиатуры.

+3
Ответы (1)
  1. 7 июня, 20:28
    0
    Var x, y, z:string; k, p, l:integer;

    begin

    writeln ('Введите строку:') ;

    readln (x) ;

    writeln ('Введите слово:') ;

    readln (y) ;

    z:=x; k:=0;

    l:=length (y) ;

    p:=pos (y, x) ;

    while p>0 do

    begin

    k:=k+1;

    delete (z, p, l) ;

    p:=pos (y, z) ;

    end;

    writeln ('k = ', k) ;

    end.

    Пример:

    Введите строку:

    мама мыла раму, мама мыла окно.

    Введите слово:

    мама

    k = 2
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Составьте программу, вычисляющую, сколько раз в строке X встречается слово Y. Строку X и слово Y введите с клавиатуры. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1. Написать программу, вычисляющую сумму отрицательных чисел, кратных 5, среди пяти, вводимых с клавиатуры. 2. Написать программу, вычисляющую произведение чисел, оканчивающихся цифрами 2 и 4, среди пяти, вводимых с клавиатуры. 3.
Ответы (1)
Задание #1 Напиши программу, вычисляющую периметр и площадь прямоугольника. Используй для этого длину и ширину прямоугольника, которые вводятся с клавиатуры.
Ответы (1)
Умоляю, помогите с Паскалем 1. Пользователь вводит неотрицательное однозначное число A. Написать программу: вычисляющую в случае ввода 1 - площадь круга с радиусом A, вычисляющую в случае ввода 2 - площадь квадрата со стороной A, вычисляющую в
Ответы (1)
Зполните экран зеленым цветом. Введите строку с клавиатуры. Введите строку в центре экрана (Pascsl abc,) помогите
Ответы (1)
Программа в Pascal 1. Написать программу которая определяет сколько раз в строке, введенной с клавиатуры, встречается буква м. 2. написать программу которая удаляет из строки, введенной с клавиатуры, все буквы о
Ответы (1)