Задать вопрос
13 января, 10:49

Одна ручка стоит A Гривен и B Копеек! Написать программу которая определяет, сколько ручек можео купить за C Гривен и D копеек, а также сколько денег останеться!

+2
Ответы (1)
  1. 13 января, 13:04
    0
    Var a, b, c, d, e, f, k, m:integer;

    begin

    writeln ('A, B:') ;

    readln (a, b) ;

    writeln ('C, D:') ;

    readln (c, d) ;

    e:=a*100+b;

    f:=c*100+d;

    k:=e div f;

    m:=e-k*f;

    writeln ('k = ', k) ;

    writeln ('Останется: ', m div 100,' гр ', m mod 100,' коп') ;

    end.

    Пример:

    A, B:

    28 15

    C, D:

    3 75

    k = 7

    Останется: 1 гр 90 коп
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Одна ручка стоит A Гривен и B Копеек! Написать программу которая определяет, сколько ручек можео купить за C Гривен и D копеек, а также ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Булка в столовой стоит A гривен B копеек. Требуется что-бы человек вводил, сколько стоит булочка в гривнах и копейках, количество булок, а на экран выводилось сколько надо гривен и копеек для покупки.
Ответы (1)
Помогите решите задачу! На языке pascal: пирожок стоит а гривен и б копеек. Определите сколько гривен и копеек надо заплатить за н пирожков Ты вводишь стоимость пирожка (гривны и копейки) и количество пирожков.
Ответы (1)
Домашнее задание: 1. Запишите на языке Паскаль программу, которая для произвольного двузначного числа определяет сумму и произведение его цифр. 2.
Ответы (1)
1. Составьте программу, которая определяет, является ли сумма цифр введенного целого трехзначного числа четным числом. 2. Составьте программу, которая определяет, является ли последняя цифра введенного целого числа нечетным числом. 8 класс.
Ответы (1)
1) Напишите программу, которая определяет, верно ли, что введенное число состоит из одинаковых цифр (например, 222) 2) Напишите программу, которая определяет, верно ли, что введеное число содержит две одинаковые цифры, стоящие рядом (например, 221)
Ответы (1)