Задать вопрос
19 февраля, 22:27

Помогите решите задачу! На языке pascal:

пирожок стоит а гривен и б копеек. Определите сколько гривен и копеек надо заплатить за н пирожков

Ты вводишь стоимость пирожка (гривны и копейки) и количество пирожков.

Пример:

10 15 2 / / вводишь ты

20 30 / / выбивает компьютер

//Без всяких 'введите количество пирожков' и. т. д.

+2
Ответы (1)
  1. 20 февраля, 01:19
    0
    Var a, b, c, e:integer;

    begin

    read (a, b) ;

    readln (c) ;

    a:=a*c;

    b:=b*c;

    e:=b div 100;

    b:=b mod 100;

    a:=a+e;

    writeln (a,' ', b)

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Помогите решите задачу! На языке pascal: пирожок стоит а гривен и б копеек. Определите сколько гривен и копеек надо заплатить за н пирожков ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Как в паскале узнать предпоследнюю цифру числа? (Очень желательно без огромных кодов на десять страниц, пример: 3456 - (вводишь ты) 5 - (выбивает компьютер)
Ответы (1)
Булка в столовой стоит A гривен B копеек. Требуется что-бы человек вводил, сколько стоит булочка в гривнах и копейках, количество булок, а на экран выводилось сколько надо гривен и копеек для покупки.
Ответы (1)
Помогите решить задачу! Пирожок в столовой стоит a рублей и b копеек. Определите, сколько рублей и копеек нужно заплатить за n пирожков. Программа получает на вход три числа: a, b, n и должна вывести два числа: стоимость покупки в рублях и копейках
Ответы (1)
Написать в тетради программу на Pascal: Спросить у пользователя три числа. Вывести сумму чисел, среднее значение. Пример: Введите а: 5 Введите b:4 Введите c:3 Сумма: 12 Среднее: 6
Ответы (1)
Как описывают переменные в Pascal? Какие стандартные числовые типы языка Pascal вам известны? Что вам известно о соответствии типов переменных в языке Pascal? Какие арифметические операции можно выполнять в Pascal?
Ответы (1)