Задать вопрос
21 января, 11:58

Cоставить программу в паскале. В одномерном массиве произвольных чисел вычислить произведение четных и нечетных элементов.

+1
Ответы (1)
  1. 21 января, 15:21
    0
    Var a : array [1 ... 10] of integer;

    I, p1, p2: integer;

    Begin

    I:=1;

    P1:=1; p2:=1;

    For i : = 1 to 10 do a[i] : = random (10) ;

    While i<=10 do begin

    If i mod 2 0 then p1:=p1 * a[i] else p2: = p2 * a[i];

    I : = i + 1;

    End;

    Write (p1,' ', p2)

    End.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Cоставить программу в паскале. В одномерном массиве произвольных чисел вычислить произведение четных и нечетных элементов. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
В одномерном массиве, состоящем из n элементов, вычислить: 1) количество отрицательных элементов массива, расположенных на четных местах 2) сумму четных элементов массива, расположенных на нечетных местах.
Ответы (1)
Помогите написать программу в паскале! Написать программу в паскале: В одномерном массиве из 10 целых чисел вычислить сумму четных чисел ...
Ответы (1)
1. В одномерном массиве подсчитать сумму тех элементов массива, которые кратны 5, но не делятся на 3. 2. В одномерном массиве подсчитать произведение тех элементов массива, которые стоя на индексах, кратных 3, а сами элементы четные.
Ответы (2)
В одномерном массиве М, состоящем из 10 целых чисел, найти: а) количество нулевых элементов: б) сумму элементов, больших - 4: В) полу сумму элементов с четными индексами: г) произведение нечетных элементов
Ответы (1)
Задачи на массивы (в паскале) : 1. Найти количество нулей в одномерном массиве. 2. найти сумму элементов кратных 5. 3. найти сумму первых 5 элементов. 4. верно ли что в массиве есть два нуля. 5. найти сумму элементов из промежутка от А до В.
Ответы (1)