Задать вопрос
25 октября, 08:42

Написать программу на Pascal, для вычисления значения функции F (x) =

а) = 0.5 при x-1

б) = 0 при x=0

в) = x+3 при x<-1

x=[-3; 4] с шагом 0,5

+1
Ответы (2)
  1. 25 октября, 09:31
    0
    На самом деле условие F (х) = 0 при х=0 лишнее, поскольку значение F (x) = 0.5x² при x≥-1 и так дает F (0) = 0.

    var

    x, F:real;

    begin

    x:=-3;

    while x<4.01 do begin

    if x<-1 then F:=x+3

    else F:=0.5*x*x;

    Writeln ('x=', x:4:1,', F=', F:5:3) ;

    x:=x+0.5

    end

    end.

    Результат

    x=-3.0, F=0.000

    x=-2.5, F=0.500

    x=-2.0, F=1.000

    x=-1.5, F=1.500

    x=-1.0, F=0.500

    x=-0.5, F=0.125

    x = 0.0, F=0.000

    x = 0.5, F=0.125

    x = 1.0, F=0.500

    x = 1.5, F=1.125

    x = 2.0, F=2.000

    x = 2.5, F=3.125

    x = 3.0, F=4.500

    x = 3.5, F=6.125

    x = 4.0, F=8.000
  2. 25 октября, 12:00
    0
    Var x:real;

    begin

    x:=-3;

    while x<=4 do begin

    if x>=1 then writeln ('F (x) = ', sqr (x) / 2) ;

    if x=0 then writeln ('F (x) = 0') ;

    if x<-1 then writeln ('F (x) = ', x+3) ;

    x: = (x+0.5) ;

    end

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Написать программу на Pascal, для вычисления значения функции F (x) = а) = 0.5 при x-1 б) = 0 при x=0 в) = x+3 при x ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Информатика pascal abc Pascal ABC задача номер 9 напишите программу вычисления y в зависимости от значения х у=1/х при х
Ответы (1)
Вычислить произведение четырех натур. чисел, используя только операцию сложения. (Язык пр:pascal) 1) Написать программу (обычную) 2) Написать программу с использованием процедуры 3) Написать программу с исп. функции 4) Написать программу с исп.
Ответы (1)
3. Написать программу, которая запрашивает ввод целого числа в переменную B и выводит это число на экран. Проверить правильность работы программы на числах 1, - 5, 256, 10455. 4.
Ответы (1)
Как описывают переменные в Pascal? Какие стандартные числовые типы языка Pascal вам известны? Что вам известно о соответствии типов переменных в языке Pascal? Какие арифметические операции можно выполнять в Pascal?
Ответы (1)
1. Напишите программу вычисления расстояния между двумя точками плоскости. 2. Напишите программу вычисления площади боковой поверхности куба. 3. Напишите программу вычисления площади и гипотенузы прямого треугольника, если известны его катеты. 4.
Ответы (1)