Задать вопрос
2 марта, 15:52

Дан массив размера N и целые числа K и L (1 ≤ K ≤ L ≤ N). Найти сумму элементов массива с номерами от K до L включительно.

+5
Ответы (2)
  1. 2 марта, 17:18
    0
    Const

    nn=100;

    var

    a:array[1 ... nn] of integer;

    i, n, k, l, s:integer;

    begin

    Randomize;

    Write ('Количество элементов в массиве: ') ; Read (n) ;

    Write ('Границы для суммирования: ') ; Read (k, l) ;

    { Считаем, что все введено корректно без проверки }

    Writeln ('Элементы массива') ;

    s:=0;

    for i:=1 to n do begin

    a[i]:=Random (100) ;

    Write (a[i],' ') ;

    if i in [k ... l] then s:=s+a[i]

    end;

    Writeln (#13#10,'Найденная сумма: ', s)

    end.

    Пример

    Количество элементов в массиве: 13

    Границы для суммирования: 3 9

    Элементы массива

    30 82 9 6 20 99 58 61 18 61 73 51 28

    Найденная сумма: 271
  2. 2 марта, 18:11
    0
    Язык не написан, значит могу написать на любом? Вот тебе jа vascript; D

    var arr = [], N, K, L, sum = 0; / / (1 < = K < = L < = N)

    N = Number (prompt ('Введите размер массива (N) ')) ;

    K = Number (prompt ('Введите K')) ;

    L = Number (prompt ('Введите L')) ;

    for (let i = 0; i < N; i++) {

    arr[i] = Math. round (Math. random () * 10) ;

    if (K = i) sum + = arr[i];

    }

    console. log ('В массиве, размерностью ${N}, состоящем из чисел [${arr}], сумма элементов с позиции ${K} до ${L} (включительно), равна ${sum}') ;

    / / Или alert (text) ;

    Лог программы:

    Введите размер массива (N) : 15

    Введите K: 3

    Введите L: 12

    В массиве, размерностью 15, состоящем из чисел [2,3,8,5,6,9,7,8,8,5,4,10,7,6,5], сумма элементов с позиции 3 до 12 (включительно), равна 69
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Дан массив размера N и целые числа K и L (1 ≤ K ≤ L ≤ N). Найти сумму элементов массива с номерами от K до L включительно. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Хотя бы 3-4 задачи! 1) Дан одномерный целочисленный массив размерностью N. Найдите количество элементов, которые кратны 3 (5). 2) Дан одномерный целочисленный массив А, состоящий из N элементов. Найти сумму всех четных элементов массива.
Ответы (1)
Помогите решить задачи на паскаль. 1) Дан массив случайных чисел (количество элементов вводите с клавиатуры). Найти произведение всех элементов массива. 2) Дан массив случайных чисел (количество элементов вводите с клавиатуры).
Ответы (1)
дан массив из семи элементов написать программу подсчитывающую среднее второго и предпоследнего элементов массива дан целочисленный массив из 10 элементов написать программу находящую сумму элементов массива красных 3 ил 5 дан целочисленный массив
Ответы (1)
1. Массив и 4 целых чисел вводится с клавиатуры. Найти и вывести произведение элементов массива. 2. Массив из 6 отрицательных и положительных целых чисел вводится в области описания констант. Найти сумму положительных элементов массива. 3.
Ответы (1)
1) Дан одномерный массив А[N], - целых чисел. Заменить все большие 7 члены массива числом 7. Найти количество таких членов. 2) Задан массив из 10 элементов, найти произведение элементов массива. Задача №3.
Ответы (1)