Задать вопрос
7 июня, 22:46

Помогите написать программу на языке Паскаль. Напишите программу, которая в последовательности натуральных чисел определяет количество чисел, кратных 4. Программа получает на вход количество чисел в последовательности, а затем сами числа.

Кто правильно напишет поставлю лучшее решение!

+4
Ответы (2)
  1. 7 июня, 23:19
    0
    Var a: array [1 ... 100] of integer;

    chis, i: integer;

    begin

    readln (chis) ;

    for i:=1 to chis do readln (a[i]) ;

    write ('Числа кратные 4:') ;

    for i:=1 to chis do if (a[i] mod 4 = 0) then write (a[i], ' ') ;

    end.
  2. 8 июня, 01:37
    0
    Var n, a, i, k:integer;

    begin

    write ('n = ') ;

    readln (n) ;

    k:=0;

    writeln ('Вводите числа:') ;

    for i:=1 to n do

    begin

    readln (a) ;

    if a mod 4 = 0 then k:=k+1;

    end;

    writeln ('k = ', k) ;

    end.

    Пример:

    n = 5

    Вводите числа:

    15

    24

    73

    48

    94

    k = 2
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Помогите написать программу на языке Паскаль. Напишите программу, которая в последовательности натуральных чисел определяет количество ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1. Напишите программу, которая в последовательности натуральных чисел определяет количество чисел, кратных 4. Программа получает на вход количество чисел в последовательности, а затем сами числа. В последовательности всегда имеется число, кратное 4.
Ответы (1)
1) Напишите программу которая в последствии натуральных чисел определяет, есть ли в последовательности нечетные числа не оканчивающихся на 1. Вход: программа получает на выход кол-во чисел, а затем сами числа.
Ответы (2)
1) Напишите программу которая в последствии натуральных чисел определяет, находит сумму двузначных чисел не кратных 4. В последовательности обязательно имеется двузначное число не кратное 4.
Ответы (1)
Программа в Паскаль. Напишите программу, которая последовательности натуральных чисел определяет количество чисел, оканчивающихся на 6. Программа получает на вход количество чисел последовательности, а затем сами числа.
Ответы (1)
Напишите программу, которая в последовательности натуральных чисел определяет сумму чисел, кратных 3. Программа получает на вход количество чисел в последовательности, а затем сами числа. В последовательности всегда имеется число, кратное 3.
Ответы (2)