Задать вопрос
9 января, 19:26

Составить алгоритм и написать решение задачи на Паскале: Три точки заданы своими координатами. Найти длины сторон треугольника и его площадь.

+5
Ответы (1)
  1. 9 января, 20:10
    0
    Program n1;

    var: x1, y1, x2, y2, x3, y3, S, p, a, b, c: real;

    begin

    readln (x1, x2, x3, y1, y2, y3) ;

    a=sqrt ((x1-x2) * (x1-x2) + (y1-y2) * (y1-y2)) ;

    b=sqrt ((x2-x3) * (x2-x3) + (y2-y3) * (y2-y3)) ;

    c=sqrt ((x3-x1) * (x3-x1) + (y3-y1) * (y3-y1)) ;

    p=0.5 * (a+b+c) ;

    S=sqrt (p * (p-a) * (p-b) * (p-c)) ;

    writeln (S) ;

    writeln (a,' ', b,' ', c) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Составить алгоритм и написать решение задачи на Паскале: Три точки заданы своими координатами. Найти длины сторон треугольника и его ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Два игрока играют в игру. На координатной плоскости стоит фишка. Игроки ходят поочереди. В начале игры фишка находится в точке с координатами (4,2).
Ответы (1)
2 задачи по программированию: 1) Три точки заданы своими координатами (x1, y1), (x2, y2), (x3, y3). Напишите программу, позволяющую выяснить, какие из них находятся на максимальном расстоянии друг от друга, и вывести на печать значение этого
Ответы (1)
1. Написать программу для решения задачи: Точки на плоскости заданы своими координатами. Определить какая из них находится ближе к началу координат.
Ответы (1)
К какому виду алгоритма относится решение линейного уравнение? А) линейный алгоритм В) Развлетвляющийся алгоритм С) Циклический алгоритм Д) лабиринт Е) Оператор алгоритм
Ответы (1)
Паскаль! На плоскости заданы три точки своими координатами. Определить расстояние от точек до начала координат и напечатать, какая из точек расположена ближе к началу координат. (с повтором)
Ответы (1)