Задать вопрос
15 июня, 00:02

Дан массив из 10 элементов. Необходимо заполнить его первыми 10 членами арифметической прогрессии с заданными первым членом прогрессии a и её разностью p.

Формат входных данных

С клавиатуры вводятся целые числа a и p (-100≤a, p≤100-100≤a, p≤100).

Формат выходных данных

Требуется вывести содержимое массива после заполнения согласно условию задачи. Элементы должны разделяться пробелами.

+5
Ответы (1)
  1. 15 июня, 02:25
    0
    Const

    n=10;

    var

    m:array[1 ... n] of integer;

    a, p, i:integer;

    begin

    Write ('Введите a, p: ') ;

    Read (a, p) ;

    for i:=1 to n do

    begin

    m[i]:=a+p * (i-1) ;

    Write (m[i],' ')

    end;

    Writeln;

    end.

    Тестовое решение

    Введите a, p: - 5 8

    -5 3 11 19 27 35 43 51 59 67
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Дан массив из 10 элементов. Необходимо заполнить его первыми 10 членами арифметической прогрессии с заданными первым членом прогрессии a и ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Дан массив из 10 элементов. Необходимо заполнить его первыми 10 членами арифметической прогрессии с заданными первым членом прогрессии aa и её разностью p. Формат входных данных С клавиатуры вводятся целые числа aa и pp (-100≤a, p≤100-100≤a, p≤100).
Ответы (1)
Дано натуральное число nn (n
Ответы (1)
Во имя радостных мессий, помогите хоть одну задачку. Не шарю ( Дан массив из 15 элементов. Необходимо заполнить его с помощью оператора присваивания (случайными числами), вывести все элементы в строку, а затем вывести произведение всех элементов
Ответы (1)
Помогите решить задачи! 1. Дан массив размера 10, числовые значения которого вводятся с клавиатуры. Вывести максимальный элемент данного массива и его номер. 2. Дан массив размера 10, числовые значения которого вводятся с клавиатуры.
Ответы (1)
H. Работа с несколькими массивами Дан массив a, состоящий из n целых чисел. Ваша задача - переписать его элементы в другой массив такого же размера следующим образом: сначала должны идти все отрицательные элементы, а затем все остальные.
Ответы (1)