Задать вопрос
12 июля, 12:50

Дан массив из 10 элементов. Необходимо заполнить его первыми 10 членами арифметической прогрессии с заданными первым членом прогрессии aa и её разностью p.

Формат входных данных

С клавиатуры вводятся целые числа aa и pp (-100≤a, p≤100-100≤a, p≤100).

Формат выходных данных

Требуется вывести содержимое массива после заполнения согласно условию задачи. Элементы должны разделяться пробелами.

+5
Ответы (1)
  1. 12 июля, 13:56
    0
    Const n=10;

    var ar:array[1 ... n] of integer;

    a, p, i:integer;

    begin

    write ('a = ') ;

    readln (a) ;

    write ('p = ') ;

    readln (p) ;

    ar[1]:=a;

    for i:=2 to n do ar[i]:=ar[i-1]+p;

    for i:=1 to n do write (ar[i],' ') ;

    end.

    Пример:

    a = 2

    p = 5

    2 7 12 17 22 27 32 37 42 47
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Дан массив из 10 элементов. Необходимо заполнить его первыми 10 членами арифметической прогрессии с заданными первым членом прогрессии aa и ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Дан массив из 10 элементов. Необходимо заполнить его первыми 10 членами арифметической прогрессии с заданными первым членом прогрессии a и её разностью p. Формат входных данных С клавиатуры вводятся целые числа a и p (-100≤a, p≤100-100≤a, p≤100).
Ответы (1)
Дано натуральное число nn (n
Ответы (1)
Во имя радостных мессий, помогите хоть одну задачку. Не шарю ( Дан массив из 15 элементов. Необходимо заполнить его с помощью оператора присваивания (случайными числами), вывести все элементы в строку, а затем вывести произведение всех элементов
Ответы (1)
Помогите решить задачи! 1. Дан массив размера 10, числовые значения которого вводятся с клавиатуры. Вывести максимальный элемент данного массива и его номер. 2. Дан массив размера 10, числовые значения которого вводятся с клавиатуры.
Ответы (1)
H. Работа с несколькими массивами Дан массив a, состоящий из n целых чисел. Ваша задача - переписать его элементы в другой массив такого же размера следующим образом: сначала должны идти все отрицательные элементы, а затем все остальные.
Ответы (1)