Задать вопрос
15 августа, 10:14

Дано четырехзначное число если сумма всех цифр кратно 5 ти найти корень квадратный от произведения первой и четвертой цифры иначе найти произведение второй и третьей цифры

+3
Ответы (1)
  1. 15 августа, 11:39
    0
    Var s: string;

    begin

    read (s) ;

    if s. Length = 4 then

    begin

    if ((strtoint (s[1]) + strtoint (s[2]) + strtoint (s[3]) + strtoint (s[4])) mod 5=0)

    then write (sqrt (strtoint (s[1]) * strtoint (s[4])))

    else write (strtoint (s[2]) * strtoint (s[3])) end;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Дано четырехзначное число если сумма всех цифр кратно 5 ти найти корень квадратный от произведения первой и четвертой цифры иначе найти ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Автомат получает на вход четырёхзначное десятичное число. По полученному числу строится новое десятичное число по следующим правилам. 1. Вычисляются два числа - сумма первой и второй цифр и сумма третьей и четвёртой цифр заданного числа. 2.
Ответы (1)
Дано четырехзначное число, если оно кратно 4, то посчитать сумму его цифр, иначе посчитать произведение цифр. Составить программу на Паскаль
Ответы (1)
Дано натуральное число: определить а) количество цифр в нем б) сумму его цифр в) произведение его цифр г) среднее арифметическое его цифр д) сумму квадратов его цифр е) сумму кубов его цифр ж) его первую цифру з) сумму его первой и последней цифр
Ответы (1)
47. дано целое четырехзначное положительное число n. составьте программу, которая определяет, какая из его цифр больше-вторая или последняя 48 дано целое четырехзначное положительное число n.
Ответы (1)
1. Дано двузначное число. Определить: a. какая из его цифр больше, первая или вторая; b. одинаковы ли его цифры. 2. Дано двухзначное число. Определить, равен ли квадрат этого числа учетверённой сумме кубов его цифр.
Ответы (1)