Задать вопрос
19 апреля, 07:54

Вычислить значения функции y = x^2+x+5, если x изменяется от - 20 до 20 с шагом 0,5.

Помогите!

+3
Ответы (1)
  1. 19 апреля, 11:30
    0
    Var

    x0, xk, dx, x: real;

    function f (x: real) : real;

    begin

    f : = x * x + x + 5;

    end;

    begin

    write ('Введите промежуток и шаг ([a, b] h) ') ;

    readln (x0, xk, dx) ;

    x : = x0;

    writeln (' x ':10, ' | ', ' f (x) ':10) ;

    repeat

    writeln (x:10:3, ' | ', f (x) : 10:3) ;

    x : = x + dx;

    until x > xk;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Вычислить значения функции y = x^2+x+5, если x изменяется от - 20 до 20 с шагом 0,5. Помогите! ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
В паскале в 3 циклах: for; repeat; white. Вычислить и напечатать значения функции и соответствующие им значения аргументов x, y. z=2xy-2yx при изменении первого аргумента x[-1; 1] с шагом 0.1 и второго аргумента y[2; 2] с шагом 0.2.
Ответы (1)
1. Определите сколько раз будет выполняться тело цикла, при вычислении:y=5x+12a на промежутке [-6; 6 ] с шагом 2. 2. Определите сколько раз будет выполняться тело цикла, при вычислении:y=7/12a на промежутке [-2; 1 ] с шагом 0,5. 3.
Ответы (1)
Дана функция y=x^3+4. Переменная х изменяется на отрезке [-2; 2] с шагом 0,5. Сформулируйте два массива X и Y. В массиве Х будут храниться значения аргумента функции на данном отрезке, а в массиве Y - соответствующие аргументам значения функции.
Ответы (1)
Вычислить значения функции y=cos3x+7 на отрезке от 9 до 25 с шагом 1. Полученные значения функции записать в массив и вывести на экран. паскаль
Ответы (1)
3. Вычислить значения функции у = sin (n*x) - cos (n/x) при n=1,2, ...,50 и изменении x в интервале [1; 3] c шагом  х=0,1. Отпечатать только отрицательные значения функции y. N эт понятно, а вот как остальное чет вообще не понял.
Ответы (1)