Задать вопрос
30 мая, 04:42

Найти средние арифметические положительных и отрицательных элементов массива, написать программу в паскале

+3
Ответы (1)
  1. 30 мая, 05:02
    0
    const

    handsfree = false;

    var

    a: array[1 ... 100] of real;

    i, n: integer;

    sum_pos, sum_neg: real;

    k_pos, k_neg: integer;

    begin

    {ввод массива}

    if handsfree then

    n : = random (20) + 5

    else begin

    write ('n = ') ;

    readln (n) ;

    end;

    writeln ('Данные массива:') ;

    for i : = 1 to n do

    begin

    if handsfree then begin

    a[i] : = random (100) - 50;

    write (a[i], ' ') ;

    end

    else readln (a[i]) ;

    end;

    writeln () ;

    {подсчет}

    sum_pos : = 0;

    k_pos : = 0;

    sum_neg : = 0;

    k_neg : = 0;

    for i : = 1 to n do

    begin

    if a[i] > 0 then

    begin

    sum_pos : = sum_pos + a[i];

    k_pos : = k_pos + 1;

    end;

    if a[i] < 0 then

    begin

    sum_neg : = sum_neg + a[i];

    k_neg : = k_neg + 1;

    end;

    end;

    writeln ('average (positives) = ', sum_pos / k_pos) ;

    writeln ('average (negatives) = ', sum_neg / k_neg) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Найти средние арифметические положительных и отрицательных элементов массива, написать программу в паскале ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Составьте программу в Паскале для поиска: a) суммы положительных элементов массива от а от 1 до 100, введенных с клавиатуры b) произведения отрицательных элементов массива а от 1 до 100 c) количества нулевых элементов массива с сотней элементов
Ответы (1)
1. Возвести в квадрат все элементы массива A. Размер массива и значения элементов массива - произвольные. 2. Увеличить на 4 все элементы в первой половине массива A (считать, что в массиве чётное число элементов).
Ответы (1)
1. Массив и 4 целых чисел вводится с клавиатуры. Найти и вывести произведение элементов массива. 2. Массив из 6 отрицательных и положительных целых чисел вводится в области описания констант. Найти сумму положительных элементов массива. 3.
Ответы (1)
1. Составить программу вывода на экран в первую строку 5 элементов массива, а во вторую - остальные 5 элементов массива; 2. Составить программу вывода элементов массива в обратном порядке; 3.
Ответы (1)
дан массив из семи элементов написать программу подсчитывающую среднее второго и предпоследнего элементов массива дан целочисленный массив из 10 элементов написать программу находящую сумму элементов массива красных 3 ил 5 дан целочисленный массив
Ответы (1)