Задать вопрос
2 февраля, 20:07

Составить алгоритм и написать решение задачи на Паскале: Даны 3 положительных числа. Найти периметр и площадь треугольника с данными сторонами.

+5
Ответы (1)
  1. 2 февраля, 23:25
    0
    Program treyg;

    var a, b, c, p:integer; s, pol:real;

    begin

    readln (a, b, c) ;

    p:=a+b+c;

    pol:=p/2;

    s:=Sqrt (pol * (pol-a) * (pol-b) * (pol-c)) ;

    Writeln ('Площадь=', s) ;

    Writeln ('Периметр = ', p)

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Составить алгоритм и написать решение задачи на Паскале: Даны 3 положительных числа. Найти периметр и площадь треугольника с данными ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Помогите с задачками в паскале. Даны три положительных числа а, в, с. Проверить будут ли они сторонами треугольника. Если да то вычислить площадь этого треугольника. Даны два действительных положительных числа х и у.
Ответы (1)
Помогите подалуйста! нужно написать алгоритм следующих 2 заданий на языке Паскаля 1. Даны два действительных положительных числа. Найдите среднее арифметическое, суму, разность и произведение этих чисел. 2 Даны катеты прямоугольного треугольника.
Ответы (2)
Хотя бы что-нибудь! Помогите решить задачи в паскале! Составить программу для: 1) Решения линейного уравнения ах + в = 0 (а, в ≠ 0).
Ответы (1)
К какому виду алгоритма относится решение линейного уравнение? А) линейный алгоритм В) Развлетвляющийся алгоритм С) Циклический алгоритм Д) лабиринт Е) Оператор алгоритм
Ответы (1)
Помогите с паскалем 1. написать алгоритм нахождения максимального среди 4 целых чисел. 2. написать алгоритм проверки: имеются ли среди трех целых чисел два положительных значения. 3.
Ответы (1)