Задать вопрос
10 ноября, 10:54

Условие этой задачи очень простое. Найдите наименьшее K такое, что K! делится на N без

остатка. K! = 1 · 2 · 3 · ... · (K - 1) · K.

Формат входных данных

В первой и единственной строке дано число N (1 ⩽ N ⩽ 109).

+5
Ответы (1)
  1. 10 ноября, 12:33
    0
    Var k, n, d, m, s:integer;

    begin

    k : = 1;

    d : = 2;

    read (n) ;

    while n > 1 do

    begin

    s : = 0;

    m : = 1;

    while n mod d = 0 do

    begin

    if m mod d 0 then

    begin

    s : = s + d;

    m : = s;

    end;

    n : = n div d;

    m : = m div d;

    end;

    if s > k then k : = s;

    d : = d + 1

    end;

    writeln (k)

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Условие этой задачи очень простое. Найдите наименьшее K такое, что K! делится на N без остатка. K! = 1 · 2 · 3 · ... · (K - 1) · K. Формат ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Числа Вам даны число N и цифра D. Выведите все N - значные числа, которые не содержат цифру D, в возрастающем порядке. Формат входных данных В единственной строке входного файла записаны число N (1 ≤ N ≤ 7) и цифра D (0 ≤ D ≤ 9).
Ответы (1)
Задача D Три числа Дан массив из N целых чисел а1, а2, ..., an. Вам нужно проверить, есть ли в этом массиве три числа сумма которых равна нулю. Формат входных данных В первой строке входного файла содержится одно целое число N (1 ≤ N ≤ 2000).
Ответы (1)
Дан массив из N целых чисел a1, a2 ..., aN. Вам нужно проверить, есть ли в этом массиве три числа сумма которых равно нулю. Формат входных данных В певой строке входного файла содержится одно целое число n (1
Ответы (1)
Найти количество целых решений, удовлетворяющих неравенству: A < B*x + C ≤ D. Формат входных данных: В единственной строке заданы четыре целых числа: A, B, C и D (0 ≤ A, B, C, D ≤ 1018, B ≠ 0).
Ответы (1)
Формат входных данных В первой строке входных данных - два числа A и B (-10000
Ответы (1)