Задать вопрос
17 ноября, 18:39

Ребят, задачка по информатике: написать программу (на языке паскаль), где дан массив целых чисел а1, а2, а3, ..., аn, и нужно упорядочить этот массив (числа должны идти по возрастанию)

+1
Ответы (1)
  1. 17 ноября, 20:41
    0
    Program n6;

    var A:array [1 ... 5] of integer;

    b, i, h:integer;

    begin

    for i:=1 to 5 do

    begin

    write ('Введите ', i,' элемент массива') ;

    readln (A[i]) ;

    end;

    for h:=1 to 25 do

    for i:=1 to 4 do

    if (A[i]>A[i+1]) then

    begin

    b:=A[i+1];

    A[i+1]:=A[i];

    A[i]:=b;

    end;

    write ('Упорядочный массив - ') ;

    for i:=1 to 5 do

    write (A[i],' ') ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Ребят, задачка по информатике: написать программу (на языке паскаль), где дан массив целых чисел а1, а2, а3, ..., аn, и нужно упорядочить ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1) Дан массив из n элементов. Найти номер наименьшего элемента массива. 2) Дан массив из n элементов. Упорядочить массив по возрастанию. 3) Дан массив из n элементов. Упорядочить массив по убыванию.
Ответы (1)
Даны три одномерных массива. Упорядочить их по возрастанию элементов. Составить программу проверки, сколько раз повторяется заданное число в каждом массиве.
Ответы (1)
Помогите написать программу в Python. 1) Дан массив, состоящий из целых чисел. Нумерация элементов начинается с 0. Напишите программу, которая выведет элементы массива, номера которых четны (0, 2, 4 ...). 2) Дан массив, состоящий из целых чисел.
Ответы (1)
дан массив из семи элементов написать программу подсчитывающую среднее второго и предпоследнего элементов массива дан целочисленный массив из 10 элементов написать программу находящую сумму элементов массива красных 3 ил 5 дан целочисленный массив
Ответы (1)
Ввести слово и число раз (Ввод; паскаль, 3). Вывести это слово так: паскаль паскаль паскаль паскаль паскаль паскаль
Ответы (1)