Задать вопрос
6 января, 22:11

Нужно определить, сколько дней в месяце по порядковому номеру заданного месяца. Здесь N (1-12) - номер месяца, A (0 или 1) - признак високосности года, 0 - простой год, 1 - високосный год. Pascal.

+5
Ответы (1)
  1. 7 января, 00:37
    0
    Var N, A:integer;

    begin

    writeln ('Введите N:') ;

    readln (N) ;

    writeln ('Введите A:') ;

    readln (A) ;

    if (N = 1) or (N = 3) or (N = 5) or (N = 7) or (N = 8) or (N = 10) or (N = 12) then

    writeln ('В месяце 31 день')

    else if (N = 4) or (N = 6) or (N = 9) or (N = 11) then

    writeln ('В месяце 30 дней')

    else if (N = 2) and (A = 0) then

    writeln ('В месяце 28 дней')

    else if (N = 2) and (A = 1) then

    writeln ('В месяце 29 дней')

    else

    writeln ('Данные введены неправильно!') ;

    readln;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Нужно определить, сколько дней в месяце по порядковому номеру заданного месяца. Здесь N (1-12) - номер месяца, A (0 или 1) - признак ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Задание 1. Ввести номер месяца и вывести количество дней в нем, а также число ошибок при вводе. Пример: Введите номер месяца: -2 Введите номер месяца: 11 В этом месяце 30 дней. Вы вводили неверно 1 раз. Задание 2.
Ответы (1)
1) Вычислить длину окружности и площадь круга одного и того же заданного радиуса R. Pascal (желательно с блок-схемой) 2) Найти сумму членов арифметической прогрессии, если известны её первый член, знаменатель и число членов прогрессии Pascal
Ответы (1)
Написать программу, определяющую количество дней в месяце Алгоритм решения задачи: Переменная d имеет тип данных запись и содержит два поля: year - для хранения года и month - для месяца. Пользователь вводит год и месяц.
Ответы (1)
На с + + Дан номер года. Требуется определить количество дней в этом году, учитывая, что обычный год насчитывает 365 дней, а високосный - - 366 дней.
Ответы (1)
Определить количество дней в году, которое вводится пользователем. Алгоритм решения задачи: В високосном году - 366 дней, в обычном 365. Високосными годами являются все года.
Ответы (1)