Задать вопрос
9 октября, 23:27

Две одномерный произвольный целочисленный массив. Вычислите сумму и количество отрицательных элементов

+2
Ответы (1)
  1. 10 октября, 00:31
    0
    Const n=10;

    var

    a:array[1 ... n] of integer;

    i, s, k:integer;

    begin

    Randomize;

    for i:=1 to n do

    begin

    a[i]:=random (51) - 25;

    write (a[i]:4) ;

    end;

    writeln;

    s:=0; k:=0;

    for i:=1 to n do

    if a[i]<0

    then begin s:=s+a[i]; k:=k+1; end;

    writeln ('s = ', s,' k = ', k) ;

    end.

    Пример:

    21 5 - 11 - 6 - 14 - 9 1 - 25 9 5

    s = - 65 k = 5
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Две одномерный произвольный целочисленный массив. Вычислите сумму и количество отрицательных элементов ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Хотя бы 3-4 задачи! 1) Дан одномерный целочисленный массив размерностью N. Найдите количество элементов, которые кратны 3 (5). 2) Дан одномерный целочисленный массив А, состоящий из N элементов. Найти сумму всех четных элементов массива.
Ответы (1)
1.) Вывести на экран одномерный целочисленный массив, состоящий из 10 целых чисел из диапазона [-100; 100] 2.) Задан одномерный целочисленный массив, состоящий из 7 случайных чисел.
Ответы (1)
дан массив из семи элементов написать программу подсчитывающую среднее второго и предпоследнего элементов массива дан целочисленный массив из 10 элементов написать программу находящую сумму элементов массива красных 3 ил 5 дан целочисленный массив
Ответы (1)
Помогите решить через паскаль 1) массив А вводится с клавиатуры, найти среднее арифметическое его элементов с нечетными номерами, размер произвольный.
Ответы (1)
1. Дан одномерный целочисленный массив. Найти числа, которые при делении на 3 и 5 дают одинаковые остатки, посчитать их количество. Если такий чисел нет, то вывести соответствующее сообщение. 1. Д ан одномерный целочисленный массив.
Ответы (1)