Задать вопрос
23 февраля, 15:05

Ввести натуральное число, N (меньше 15) и найти произведение всех чисел от 1 до N (1*2*3 * ... * N).

(Составьте алгоритм)

+3
Ответы (1)
  1. 23 февраля, 16:03
    0
    Программа на паскале (программа - это один из способов записи алгоритма).

    var n, p, i:integer;

    begin

    write ('n = ') ;

    readln (n) ;

    p:=1;

    for i:=1 to n do p:=p*i;

    writeln ('p = ', p) ;

    end.

    Пример:

    n = 7

    p = 5040
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Ввести натуральное число, N (меньше 15) и найти произведение всех чисел от 1 до N (1*2*3 * ... * N). (Составьте алгоритм) ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Помогите написать программу Паскаль, очень прошу, вообще не шарю в программах, а так 2 поставят! Задача "A": Ввести натуральное число и найти сумму его цифр. Пример: Введите натуральное число: 12345. Сумма цифр 15.
Ответы (2)
Ниже на пяти языках программирования записан алгоритм. Получив на вход натуральное число x, этот алгоритм печатает число R. Укажите такое число x, при вводе которого алгоритм печатает двузначное число, сумма цифр которого равна 13.
Ответы (1)
1) Ввести натуральное число и определить, верно ли, что в его записи есть две одинаковые цифры, стоящие рядом. 2) Ввести натуральное число и определить, верно ли, что в его записи есть две одинаковые цифры (не обязательно стоящие рядом).
Ответы (1)
Python. Уровень B. Ввести натуральное число и определить, верно ли, что в его записи есть две одинаковые цифры, стоящие рядом. Пример: Введите натуральное число: 12342 Нет. Пример: Введите натуральное число: 12245 Да.
Ответы (1)
1) Ввести число. Если оно неотрицательно (больше 0), вычесть из него 10, иначе - прибавить к нему 10 2) Ввести 2 числа.
Ответы (1)