Задать вопрос
26 июля, 23:03

Напишите программу: ввести четырехзначное число, найти сумму крайних и сумму средних цифр

+3
Ответы (1)
  1. 27 июля, 00:27
    0
    На Pascal:

    program sum4; uses crt; var a:integer;

    begin writeln ('Введите 4-х значное число') ; readln (a) ; writeln ('Сумма крайних цифр = ', (a mod 10) + (a div 1000)) ; writeln ('Сумма средних цифр = ', ((a div 100) mod 10) + (a div 10) mod 10) ; end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Напишите программу: ввести четырехзначное число, найти сумму крайних и сумму средних цифр ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Автомат получает на вход четырехзначное десятичное число. По полученному числу строится новое десятичное число по следующим правилам: 1) вычисляются два числа - сумма "кратчайших" цифр четырехзначного числа, а также сумма "средних" цифр заданного
Ответы (1)
Написать программу: с клавиатуры вводится четырехзначное целое число. Вывести на экран сообщение о соотношении суммы крайних цифр и суммы средних цифр этого числа (меньше, больше или равны).
Ответы (1)
Дано натуральное число: определить а) количество цифр в нем б) сумму его цифр в) произведение его цифр г) среднее арифметическое его цифр д) сумму квадратов его цифр е) сумму кубов его цифр ж) его первую цифру з) сумму его первой и последней цифр
Ответы (1)
Помогите составить программу на языке С! С клавиатуры вводится целое число. Определить кол-во цифр в нем, сумму его цифр, произведение его цифр, среднее арифметическое его цифр, сумму квадратов его цифр, сумму кубов его цифр.
Ответы (1)
Помогите написать программу Паскаль, очень прошу, вообще не шарю в программах, а так 2 поставят! Задача "A": Ввести натуральное число и найти сумму его цифр. Пример: Введите натуральное число: 12345. Сумма цифр 15.
Ответы (2)