Задать вопрос
27 октября, 14:07

Написать программу: с клавиатуры вводится четырехзначное целое число. Вывести на экран сообщение о соотношении суммы крайних цифр и суммы средних цифр этого числа (меньше, больше или равны).

+3
Ответы (1)
  1. 27 октября, 15:44
    0
    Var a, a1, a2, a3, a4, s1, s2:integer;

    begin

    readln (a) ;

    a1:=a div 1000;

    a2:=a div 100 mod 10;

    a3:=a mod 100 div 10;

    a4:=a mod 10;

    s1:=a1+a4; s2:=a2+a3;

    if s1>s2 then writeln (s1,' > ', s2)

    else if s1
    else writeln (s1,' = ', s2) ;

    end.

    Пример:

    4382

    6 < 11
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Написать программу: с клавиатуры вводится четырехзначное целое число. Вывести на экран сообщение о соотношении суммы крайних цифр и суммы ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Напишите задачи в Паскале задача1 {вводится целое число n от [0 ... 200]. Затеи вводится n целых чисел от [0 ... 1000000] Вывести на экран их произведение.} задача2 {вводится целое число n от [0 ... 200]. Затеи вводится n целых чисел от [0 ...
Ответы (2)
1. Пользователем вводится целое число. Вывести на экран последовательность целых чисел от единицы до этого числа. 2. Вывести на экран 10 строк, содержащие символ *, причем количество * в каждой строке должно быть равно номеру строки. 3.
Ответы (1)
Pascal. Тема: Циклы С клавиатуры вводится целое произвольное число 1) Вывести на экран первую и последнюю цифру числа. 2) Вывести на экран наибольшую цифру числа 3) Вывести на экран нечетные цифры этого числа
Ответы (2)
Помогите решить 3. С клавиатуры вводится четырехзначное число. Получить число, равное произведению его цифр. 4. С клавиатуры вводится натуральное число п. Узнайте в нем количество цифр. 5. С клавиатуры вводится натуральное число п.
Ответы (1)
Паскаль. 1. вывести на экран все четные числа от 1 до n. 2. вывести на экран все трехзначные числа. 3. вывести на экран четырехзначные числа оканчивающийся на 7. 4. вывести на экран все трехзначные и двухзначные числа сумма цифр которых равна девяти.
Ответы (1)