Задать вопрос
14 апреля, 03:00

дан массив 0 из 6 элементов. найти среднее арифметического элементов этого массива. в паскале

+1
Ответы (2)
  1. 14 апреля, 05:38
    0
    const n = 6;

    var

    a: array[1 ... n] of integer;

    i, s: integer;

    begin

    for i : = 1 to n do begin

    a[i] : = random (20) ;

    s : = s + a[i];

    write (a[i], ' ') ;

    end;

    writeln;

    writeln ('Среднее арифметическое эл. массива: ', s / n) ;

    end.
  2. 14 апреля, 06:33
    0
    Program Tanina_domashka;

    i:byte;

    summa:integer;

    o:array[1 ... 6] of integer;

    Begin

    Writeln ('Массив') ;

    For i:=1 to 6 do

    Begin

    o[i]:=random (1001) - 500;

    Writeln ('Элемент массива №', i,' = ', o[i]) ;

    End;

    For i:=1 to 6 do

    summa:=summa+o[i];

    Writeln ('Среднее арифметическое элементов массива = ', summa/6) ;

    End.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «дан массив 0 из 6 элементов. найти среднее арифметического элементов этого массива. в паскале ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Хотя бы 3-4 задачи! 1) Дан одномерный целочисленный массив размерностью N. Найдите количество элементов, которые кратны 3 (5). 2) Дан одномерный целочисленный массив А, состоящий из N элементов. Найти сумму всех четных элементов массива.
Ответы (1)
дан массив из семи элементов написать программу подсчитывающую среднее второго и предпоследнего элементов массива дан целочисленный массив из 10 элементов написать программу находящую сумму элементов массива красных 3 ил 5 дан целочисленный массив
Ответы (1)
Помогите решить задачи на паскаль. 1) Дан массив случайных чисел (количество элементов вводите с клавиатуры). Найти произведение всех элементов массива. 2) Дан массив случайных чисел (количество элементов вводите с клавиатуры).
Ответы (1)
1) Дан одномерный массив А[N], - целых чисел. Заменить все большие 7 члены массива числом 7. Найти количество таких членов. 2) Задан массив из 10 элементов, найти произведение элементов массива. Задача №3.
Ответы (1)
1) Дан массив из n элементов. Найти номер наименьшего элемента массива. 2) Дан массив из n элементов. Упорядочить массив по возрастанию. 3) Дан массив из n элементов. Упорядочить массив по убыванию.
Ответы (1)