Задать вопрос
29 октября, 14:36

дан массив из четного числа элементов. поменять местами его половины

+1
Ответы (1)
  1. 29 октября, 16:50
    0
    const

    N = 20;

    var

    A : array [1 ... N] of Integer;

    Pos, Sum, Znak : Integer;

    begin

    Write ('Массив: ') ;

    Randomize;

    for Pos : = 1 to N do

    begin

    A[Pos] : = Random (101) - 50;

    Write (A[Pos]:4) ;

    end;

    WriteLn;

    for Pos : = 1 to N div 2 do Sum : = Sum + A[Pos] - A[N div 2 + Pos];

    WriteLn ('Разность между суммой 1-й половины и 2-й = ', Sum) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «дан массив из четного числа элементов. поменять местами его половины ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Хотя бы 3-4 задачи! 1) Дан одномерный целочисленный массив размерностью N. Найдите количество элементов, которые кратны 3 (5). 2) Дан одномерный целочисленный массив А, состоящий из N элементов. Найти сумму всех четных элементов массива.
Ответы (1)
1) Дан массив из n элементов. Найти номер наименьшего элемента массива. 2) Дан массив из n элементов. Упорядочить массив по возрастанию. 3) Дан массив из n элементов. Упорядочить массив по убыванию.
Ответы (1)
дан массив из семи элементов написать программу подсчитывающую среднее второго и предпоследнего элементов массива дан целочисленный массив из 10 элементов написать программу находящую сумму элементов массива красных 3 ил 5 дан целочисленный массив
Ответы (1)
Помогите решить задачи на паскаль. 1) Дан массив случайных чисел (количество элементов вводите с клавиатуры). Найти произведение всех элементов массива. 2) Дан массив случайных чисел (количество элементов вводите с клавиатуры).
Ответы (1)
1) Дан одномерный массив А[N], - целых чисел. Заменить все большие 7 члены массива числом 7. Найти количество таких членов. 2) Задан массив из 10 элементов, найти произведение элементов массива. Задача №3.
Ответы (1)