Задать вопрос
22 сентября, 04:23

вводится число Н. а за ним Н целых чисел-элементов массива. обнулите все отрицательные элементы массива и посчитайте количество остальных. через паскаль абс

+4
Ответы (1)
  1. 22 сентября, 05:35
    0
    program dds;

    const n = 10;

    var a:array[1 ... n]of integer;

    i, o, z, x, h:integer;

    begin z:=0;

    for i:=1 to n do begin a[i]:=random (10) - 5;

    write (a[i]:4) ; end; writeln;

    write ('vvedite H') ;

    readln (H) ;

    for i:=h+1 to n do begin if a[i]<0

    then a[i]:=0; if a[i]>0 then z:=z+1; end;

    for i:=1 to n do write (a[i]:4) ; writeln;

    write ('chishel=', z) ; readln;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «вводится число Н. а за ним Н целых чисел-элементов массива. обнулите все отрицательные элементы массива и посчитайте количество остальных. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1. Возвести в квадрат все элементы массива A. Размер массива и значения элементов массива - произвольные. 2. Увеличить на 4 все элементы в первой половине массива A (считать, что в массиве чётное число элементов).
Ответы (1)
Все задачи делаются в Паскале! 1) Увеличить все элементы массива A на 1. 2) Умножить все элементы массива A на 2. 3) Возвести в квадрат все элементы массива A.
Ответы (1)
1. Массив и 4 целых чисел вводится с клавиатуры. Найти и вывести произведение элементов массива. 2. Массив из 6 отрицательных и положительных целых чисел вводится в области описания констант. Найти сумму положительных элементов массива. 3.
Ответы (1)
Напишите задачи в Паскале задача1 {вводится целое число n от [0 ... 200]. Затеи вводится n целых чисел от [0 ... 1000000] Вывести на экран их произведение.} задача2 {вводится целое число n от [0 ... 200]. Затеи вводится n целых чисел от [0 ...
Ответы (2)
Составить программу на языке Паскаль: 1) Для массива K из 12 вещественных чисел определить сколько элементов массива меньше 0. 2) В массиве М из 10 целых чисел найти количество элементов равных 3.
Ответы (1)