Задать вопрос
17 января, 21:41

Дан массив mxm. Найти сумму элементов тех столбцов, у которых диагональный элемент равен нулю.

+1
Ответы (1)
  1. 18 января, 00:03
    0
    Program PR1;

    uses crt;

    var mas:array[1 ... 10,1 ... 10] of integer;

    i, j, b:integer;

    Begin

    clrscr;

    randomize;

    for i:=1 to 10 do

    for j:=1 to 10 do mas[i, j]:=random (10) ;

    for i:=1 to 10 do

    for j:=1 to 10 do begin

    gotoxy (j, i) ;

    write (mas[i, j]) ;

    end;

    b:=0;

    for i:=1 to 10 do

    for j:=1 to 10 do if (j=i) and (mas[i, j]=0) then b:=b+mas[i, j];

    writeln;

    writeln (b) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Дан массив mxm. Найти сумму элементов тех столбцов, у которых диагональный элемент равен нулю. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Хотя бы 3-4 задачи! 1) Дан одномерный целочисленный массив размерностью N. Найдите количество элементов, которые кратны 3 (5). 2) Дан одномерный целочисленный массив А, состоящий из N элементов. Найти сумму всех четных элементов массива.
Ответы (1)
Помогите решить задачи на паскаль. 1) Дан массив случайных чисел (количество элементов вводите с клавиатуры). Найти произведение всех элементов массива. 2) Дан массив случайных чисел (количество элементов вводите с клавиатуры).
Ответы (1)
1) Дан массив из n элементов. Найти номер наименьшего элемента массива. 2) Дан массив из n элементов. Упорядочить массив по возрастанию. 3) Дан массив из n элементов. Упорядочить массив по убыванию.
Ответы (1)
дан массив из семи элементов написать программу подсчитывающую среднее второго и предпоследнего элементов массива дан целочисленный массив из 10 элементов написать программу находящую сумму элементов массива красных 3 ил 5 дан целочисленный массив
Ответы (1)
1. заполните одномерный массив B1 размерностью в N (< 30 задает пользователь при выполнении программы) элементов так, чтобы каждый элемент с четным номером был равен половине своего номера, а каждый элемент с нечетным номером - количеству элементов
Ответы (1)