Задать вопрос
28 января, 09:15

в паскале задачи решить (программу написать)

1) найти сумму элементов от А до Б

2) вывести все элементы от А до Б при любых значениях А и Б (целых)

+1
Ответы (1)
  1. 28 января, 12:30
    0
    Program n1;

    Uses CRT;

    Var a, b, s, i: integer;

    begin

    writeln ('Vvedite A i B') ;

    readln (a, b) ;

    If a>b then

    for i:=b to a do

    begin

    writeln (i) ;

    s:=s+i;

    end

    else

    if b>a then

    for i:=a to b do

    begin

    writeln (i) ;

    s:=s+i;

    end

    else writeln ('ravny') ;

    writeln ('Summa = ', s) ;

    readln

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «в паскале задачи решить (программу написать) 1) найти сумму элементов от А до Б 2) вывести все элементы от А до Б при любых значениях А и Б ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Во имя радостных мессий, помогите хоть одну задачку. Не шарю ( Дан массив из 15 элементов. Необходимо заполнить его с помощью оператора присваивания (случайными числами), вывести все элементы в строку, а затем вывести произведение всех элементов
Ответы (1)
Все задачи делаются в Паскале! 1) Увеличить все элементы массива A на 1. 2) Умножить все элементы массива A на 2. 3) Возвести в квадрат все элементы массива A.
Ответы (1)
1. Массив и 4 целых чисел вводится с клавиатуры. Найти и вывести произведение элементов массива. 2. Массив из 6 отрицательных и положительных целых чисел вводится в области описания констант. Найти сумму положительных элементов массива. 3.
Ответы (1)
дан массив из семи элементов написать программу подсчитывающую среднее второго и предпоследнего элементов массива дан целочисленный массив из 10 элементов написать программу находящую сумму элементов массива красных 3 ил 5 дан целочисленный массив
Ответы (1)
1) Заполнить массив размером N целыми числами последовательно от 1 до N. Вывести его на экран. Найти сумму элементов массива и вывести ее на экран. 2) Заполнить массив размером N целыми числами последовательно от N до 1. Вывести его на экран.
Ответы (1)