Задать вопрос
11 июля, 21:17

Составить программу,

которая проверяла бы, не приводит ли суммирование двух целых чисел А и В к

переполнению (т. е. к результату большему чем 32 767). Если будет переполнение,

то сообщить об этом, иначе вывести сумму этих чисел.

+3
Ответы (2)
  1. 11 июля, 22:16
    0
    Var

    a, b, s : Integer;

    begin

    Write ('введите a = ') ;

    readln (a) ;

    Write ('введите b = ') ;

    readln (b) ;

    S:=a+b;

    if s<32767 then writeln (s) else writeln ('произошло переполнение') ;

    end.
  2. 11 июля, 22:16
    0
    Int A, B, Summ

    A+B=Summ

    if (Summ>32767) cout>>"П ереполнение "

    else cout>>"Summ"
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Составить программу, которая проверяла бы, не приводит ли суммирование двух целых чисел А и В к переполнению (т. е. к результату большему ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
46. Составить программу, которая проверяла бы, не приводит ли суммирование двух целых чисел А и В к переполнению (т. е. к результату большему чем 32 767). Если будет переполнение, то сообщить об этом, иначе вывести сумму этих чисел. Через Дельфи
Ответы (1)
Напишите программу, которая проверяет, не приведет ли суммирование двух заданных целых чисел (Определенного типа) к переполнению.
Ответы (1)
1) Найдите сумму натуральных нечетных чисел не превышающих n! Это нужно сделать циклом for. 2) Составьте программу, которая производит суммирование произвольного количества целых чисел вводимых с клавиатуры.
Ответы (1)
Задача 1 - Дано целое число. Если оно положительное, вывести " Число положительное ", если отрицательное вывести "Число отрицательное ", если равно 0 - "Число равно нулю" задача 2 - дано целое число.
Ответы (1)
1) напишите программу, которая спрашивает целое число n и считает сумму целых чисел, Муму чётных чисел и сумму нечётных от 1 до n 2) напишите программу, которая спрашивает целые числа а и b и выводит на экран квадраты чисел от а до b 3) напишите
Ответы (1)