Задать вопрос
8 мая, 10:23

Напишите программу, которая проверяет, не приведет ли суммирование двух заданных целых чисел (Определенного типа) к переполнению.

+4
Ответы (1)
  1. 8 мая, 13:07
    0
    Const

    low=-32768;

    high=32767;

    Var i, j : integer;

    begin

    readln (i, j) ;

    if sign (i) * sign (j) <0 then writeln ('Сложение допустимо, результат ', i+j)

    else

    if i<0 then

    if j
    else writeln ('Сложение допустимо, результат ', i+j)

    else

    if j>high-i then writeln ('Сложение недопустимо: возникнет переполнение')

    else writeln ('Сложение допустимо, результат ', i+j)

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Напишите программу, которая проверяет, не приведет ли суммирование двух заданных целых чисел (Определенного типа) к переполнению. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Составить программу, которая проверяла бы, не приводит ли суммирование двух целых чисел А и В к переполнению (т. е. к результату большему чем 32 767). Если будет переполнение, то сообщить об этом, иначе вывести сумму этих чисел.
Ответы (2)
46. Составить программу, которая проверяла бы, не приводит ли суммирование двух целых чисел А и В к переполнению (т. е. к результату большему чем 32 767). Если будет переполнение, то сообщить об этом, иначе вывести сумму этих чисел. Через Дельфи
Ответы (1)
1) напишите программу, которая спрашивает целое число n и считает сумму целых чисел, Муму чётных чисел и сумму нечётных от 1 до n 2) напишите программу, которая спрашивает целые числа а и b и выводит на экран квадраты чисел от а до b 3) напишите
Ответы (1)
Помогите написать программу в Python. 1) Дан массив, состоящий из целых чисел. Нумерация элементов начинается с 0. Напишите программу, которая выведет элементы массива, номера которых четны (0, 2, 4 ...). 2) Дан массив, состоящий из целых чисел.
Ответы (1)
1) Найдите сумму натуральных нечетных чисел не превышающих n! Это нужно сделать циклом for. 2) Составьте программу, которая производит суммирование произвольного количества целых чисел вводимых с клавиатуры.
Ответы (1)