Задать вопрос
11 декабря, 08:26

ввести несколько чисел, определить каких чисел больше - положительных или отрицательных

+1
Ответы (2)
  1. 11 декабря, 09:34
    0
    например: 22, 4, 5, 8, 6, 13, 654 ... - 2, - 54, - 212, - 51, - 9 ...

    положительных: 7

    отрицательных: 5

    ответ: положительных чисел больше чем отрицательных (7>5)

    просто любые числа возьми и потом посчитай их ... или там уже даны числа?
  2. 11 декабря, 10:36
    0
    var

    countp, countm : integer;

    tmp : real;

    begin

    countp : = 0;

    countm : = 0;

    while not eoln do

    begin

    read (tmp) ;

    if tmp >0 then inc (countp)

    else if tmp < 0 then inc (countm) ;

    end;

    if countp > countm then writeln ('Положительных')

    else if countp < countm then writeln ('Отрицательных')

    else writeln ('Равно') ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «ввести несколько чисел, определить каких чисел больше - положительных или отрицательных ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Подсчитайте, сколько среди данных N чисел нулей, положительных чисел, отрицательных чисел. Вводится число N, а затем N чисел. Необходимо вывести сначала число нулей, затем число положительных и отрицательных чисел.
Ответы (1)
1. Ввести с клавиатуры длину и ширину прямоугольной двери. Кроме того, ввести длину, ширину и высоту шкафа - прямоугольного параллелепипеда. Выяснить, можно ли пронести шкаф через дверь, не разбирая его. 2. Ввести три вещественных числа с клавиатуры.
Ответы (1)
Ввести с клавиатуры 9 производных чисел (положительных и отрицательных). Вычислить среднее арифметическое нечетных и отрицательных из них. Нужна программа для паскаля.
Ответы (1)
Напишите программу на Паскале. Дан массив положительных и отрицательных чисел. Вычислить сумму положительных и произведение отрицательных чисел. А[1 ... 10]
Ответы (1)
Дано массив с N положительных и отрицательных чисел. а) найти среднее аримфметичкое отдельно для положительных, среднее геометрическое - для негативных. б) найти максимальную по длинне последовательность чисел с одинаковым знаком.
Ответы (1)