Задать вопрос
8 марта, 08:10

Вычислить суммы элементов главной диагонали квадратной матрицы

+1
Ответы (2)
  1. 8 марта, 10:32
    0
    var

    n, i, j, summ:integer;

    a:array[1 ... 100, 1 ... 100] of integer;

    begin

    write ('n = ') ; readln (n) ;

    writeln ('Исходный массив: ') ;

    for i : = 1 to n do

    begin

    for j : = 1 to n do

    begin

    a[i, j] : = random (21) ;

    write (a[i, j]:4) ;

    end;

    writeln;

    end;

    summ : = 0;

    for i : = 1 to n do

    summ : = summ + a[i, i];

    writeln ('Сумма элементов стоящих на главной диагонали равна ', summ) ;

    end.
  2. 8 марта, 11:31
    0
    program sum_dia;

    const r=10;

    var a:array[1 ... r, 1 ... r] of shortint;

    n, i, j:byte;

    s:shortint;

    begin

    randomize;

    n: = random (8) + 3;

    writeln ('Заданная матрица, порядкa ', n,':') ;

    for i:=1 to n do

    begin

    for j:=1 to n do

    begin

    a[ i, j ]:=random (21) - 10;

    write (a[ i, j ]:4) ;

    end;

    writeln

    end;

    s : = 0;

    for i: = 1 to n do

    s:=s + a[ i, i ];

    writeln ('Сумма элементов главной диагонали: ', s) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Вычислить суммы элементов главной диагонали квадратной матрицы ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Напишите программу, которая обнуляет все элементы квадратной матрицы, расположенные выше главной диагонали. Входные данные В первой строке записаны через пробел размер квадратной матрицы N (количество строк равно количеству столбцов) (1 ≤ N ≤ 100).
Ответы (1)
Для матрицы размером в n строк и m столбцов составить алгоритм и программу вычисления: 1) Сумм элементов каждой нечетной строки матрицы 2) Суммы произведений тангенсов элементов четных строк матрицы.
Ответы (1)
Перед вами часть кода программы на языке Pascal. sum:=0; for i:=1 to n do for j:=1 to n do if (i
Ответы (1)
Задан двухмерный массив чисел. Значения элементов матрицы формируются случайным образом. Вычислить произведение суммы элементов главной диагонали на сумму элементов каждой строки
Ответы (1)
Информатика. Массивы. PascalABC. 1. В двумерном массиве 4 х5 вычислить сумму элементов кратных 3, значения которых больше 20. 2. Найти среднее арифметическое элементов главной диагонали квадратной матрицы 5 х5.
Ответы (1)