Задать вопрос
20 августа, 16:11

Дан двумерный массив размерностью n*m. Заменить все отрицательные элементы на противоположные. (помогите составить программу для паскаля).

+1
Ответы (2)
  1. 20 августа, 16:52
    0
    const NN=50;

    var

    a:array [1 ... NN, 1 ... NN] of integer;

    i, j, m, n:integer;

    begin

    write ('Введите n: ') ;

    readln (n) ;

    write ('Введите m: ') ;

    readln (m) ;

    for i: = 1 to n do

    for j: = 1 to m do

    readln (a[i, j]) ;

    for i: = 1 to n do

    for j: = 1 to m do

    if a[i, j]<0 then a[i, j]:=abs (a[i, j]) ;

    for i: = 1 to n do

    begin

    for j: = 1 to m do

    write (a[i, j],' ') ;

    writeln;

    end;

    end.
  2. 20 августа, 17:27
    0
    Program a1;

    Uses crt;

    const n=8;

    m=8;

    Var a:array[1 ... n, 1 ... m] of integer;

    i, j:byte;

    Begin

    Writeln ('Исходная матрица') ;

    For i:=1 to n do

    begin

    Writeln;

    For j: = 1 to m do

    begin

    a[i, j]:=random (101) - 50;

    Write (a[i, j],' ') ;

    end;

    end;

    Writeln;

    Writeln ('Отредактированная матрица') ;

    For i:=1 to n do

    begin

    Writeln;

    For j: = 1 to m do

    begin

    If a[i, j]<0 then a[i, j]:=abs (a[i, j]) ;

    Write (a[i, j],' ') ;

    end;

    end;

    End.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Дан двумерный массив размерностью n*m. Заменить все отрицательные элементы на противоположные. (помогите составить программу для паскаля). ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Хотя бы 3-4 задачи! 1) Дан одномерный целочисленный массив размерностью N. Найдите количество элементов, которые кратны 3 (5). 2) Дан одномерный целочисленный массив А, состоящий из N элементов. Найти сумму всех четных элементов массива.
Ответы (1)
1. Дан одномерный массив размерностью 10, заполненный целыми числами, введенными с клавиатуры, и величина N. Отрицательные элементы заменить на N. Измененный массив вывести на экран одной строкой. 2.
Ответы (1)
Дан двумерный массив Х из вещественных элементов размерностью n 1. В одномерный массив переписать отрицательные элементы двумерного массива, расположенные ниже главной диагонали 2.
Ответы (1)
1. Дан двумерный массив размером 3x5. Вычислить сумму элементов массива 2. Дан массив целых чисел размеров 4 х4. Заменить все элементы главной диагонали на нули. Вывести на экран монитора содержимое массива до обработки и после обработки 3.
Ответы (1)
Помогите написать программу в Python. 1) Дан массив, состоящий из целых чисел. Нумерация элементов начинается с 0. Напишите программу, которая выведет элементы массива, номера которых четны (0, 2, 4 ...). 2) Дан массив, состоящий из целых чисел.
Ответы (1)