Задать вопрос
7 ноября, 00:23

Дан массив целых чисел B (15), найти произведения элементов массива кратных х.

+5
Ответы (1)
  1. 7 ноября, 00:31
    0
    const

    n = 15;

    var

    a:array[1 ... n] of integer;

    i, x, pr:integer;

    begin

    for i : = 1 to n do

    begin

    write ('a[', i, '] = ') ;

    readln (a[i]) ;

    end;

    write ('x = ') ; readln (x) ;

    writeln ('Исходный массив:') ;

    pr : = 1;

    for i : = 1 to n do

    begin

    write (a[i], ' ') ;

    if a[i] mod x = 0 then

    pr : = pr * a[i];

    end;

    writeln;

    if pr = 1 then

    writeln ('Нет ни одного элемента кратного ', x)

    else

    writeln ('Произведение элементов кратных ', x, ' = ', pr) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Дан массив целых чисел B (15), найти произведения элементов массива кратных х. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Помогите решить задачи на паскаль. 1) Дан массив случайных чисел (количество элементов вводите с клавиатуры). Найти произведение всех элементов массива. 2) Дан массив случайных чисел (количество элементов вводите с клавиатуры).
Ответы (1)
Хотя бы 3-4 задачи! 1) Дан одномерный целочисленный массив размерностью N. Найдите количество элементов, которые кратны 3 (5). 2) Дан одномерный целочисленный массив А, состоящий из N элементов. Найти сумму всех четных элементов массива.
Ответы (1)
1. Массив и 4 целых чисел вводится с клавиатуры. Найти и вывести произведение элементов массива. 2. Массив из 6 отрицательных и положительных целых чисел вводится в области описания констант. Найти сумму положительных элементов массива. 3.
Ответы (1)
1) Дан одномерный массив А[N], - целых чисел. Заменить все большие 7 члены массива числом 7. Найти количество таких членов. 2) Задан массив из 10 элементов, найти произведение элементов массива. Задача №3.
Ответы (1)
дан массив из семи элементов написать программу подсчитывающую среднее второго и предпоследнего элементов массива дан целочисленный массив из 10 элементов написать программу находящую сумму элементов массива красных 3 ил 5 дан целочисленный массив
Ответы (1)