Задать вопрос
23 октября, 06:15

составьте программу которая заполняет массив а [1 ... 20] случайными целыми числами в диапазоне от 1 до 10 и находит среднее арифметическое элементов с четными значениями и нечётными индексами

+3
Ответы (1)
  1. 23 октября, 06:20
    0
    var a:array[1 ... 20] of integer; i, arf, k:integer;

    begin

    k:=0;

    for i:=1 to 20 do

    begin

    a[i]:=random (10) ;

    if (a[i]/2=a[i] div 2) or (i/2i div 2) then

    begin arf:=arf+a[i]; inc (k) ; end;

    end;

    arf:=round (arf/k) ;

    for i:=1 to 20 do writeln ('a[', i,'] = ', a[i]) ;

    writeln ('Srendee arirfm. chentix chisel u nechetnix indexov = ', arf) ;

    readln;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «составьте программу которая заполняет массив а [1 ... 20] случайными целыми числами в диапазоне от 1 до 10 и находит среднее арифметическое ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Решите задачи: 1) Составьте программу ввода элементов массива [1 ... 8] с клавиатуры и вывода на экран элементов массива с отрицательными значениями. 2) Составьте программу, которая заполняет массив а [1 ...
Ответы (1)
Решить не могу задачи по информатике: 1. Составьте программу ввода элементов массива h [1 ... 8] с клавиатуры и вывода на экран элементов с отрицательными значениями. 2. Составьте программу, которая заполняет массив h [1 ...
Ответы (1)
Составьте программу которая заполняет массив s [1 ... 15] случайными целыми числами в диапазоне от 1 до 15 и находит среднее арифметическое элементов с четными значениями и четными индексами
Ответы (1)
1) Составьте программу, которая заполняет массив а[1 ... 20] случайными целыми числами в диапазоне от 1 до 10 и находит среднее арефметическое элементов с четными значениями и нечетными индексами.
Ответы (1)
1. Cоставьте программу, которая заполняет массив a [1 ... 10] случайными целыми числами в диапазоне от 1 до 10, затем преобразовывает его, увеличивая все элементы с чётными значениями на 1.
Ответы (1)