Задать вопрос
20 сентября, 08:31

Составьте программу которая заполняет массив s [1 ... 15] случайными целыми числами в диапазоне от 1 до 15 и находит среднее арифметическое элементов с четными значениями и четными индексами

+5
Ответы (1)
  1. 20 сентября, 10:20
    0
    Если в паскале то вот

    vara:array [1 ... 30] of integer; i, s, k, n:integer; h:real; begins:=0; k:=0; writeln ('введите количество чисел') ; read (n) ; randomize; for i:=1 to n do begina[i]:=random (100) ; write (a[i]:3) ; end; writeln () ; for i:=1 to n do beginif (a[i] mod 2=0) and (i mod 2=0) then begins:=s+a[i]; k:=k+1; end; end; if k>1 then h:=s/k; writeln (h) ; if k=0 then begin writeln ('таких чисел нет') ; read; halt; end; end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Составьте программу которая заполняет массив s [1 ... 15] случайными целыми числами в диапазоне от 1 до 15 и находит среднее арифметическое ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Решите задачи: 1) Составьте программу ввода элементов массива [1 ... 8] с клавиатуры и вывода на экран элементов массива с отрицательными значениями. 2) Составьте программу, которая заполняет массив а [1 ...
Ответы (1)
Решить не могу задачи по информатике: 1. Составьте программу ввода элементов массива h [1 ... 8] с клавиатуры и вывода на экран элементов с отрицательными значениями. 2. Составьте программу, которая заполняет массив h [1 ...
Ответы (1)
1. Cоставьте программу, которая заполняет массив a [1 ... 10] случайными целыми числами в диапазоне от 1 до 10, затем преобразовывает его, увеличивая все элементы с чётными значениями на 1.
Ответы (1)
составьте программу которая заполняет массив а [1 ... 20] случайными целыми числами в диапазоне от 1 до 10 и находит среднее арифметическое элементов с четными значениями и нечётными индексами
Ответы (1)
1) Составьте программу, которая заполняет массив а[1 ... 20] случайными целыми числами в диапазоне от 1 до 10 и находит среднее арефметическое элементов с четными значениями и нечетными индексами.
Ответы (1)