Задать вопрос
21 февраля, 05:46

дан массив, содержащий 70 неотрицательных целых чисел, не привышающих 1000. Опишите на одном из языков программирования алгоритм, позволяющий найти и вывести сумму двух соседних элементов массива, имеющих одинаковую чётность. Гарантируется, что в массиве есть соседние элементы, имеющие одинаковую чётность.

+3
Ответы (1)
  1. 21 февраля, 09:26
    0
    program mas;

    uses crt;

    var A:array [1 ... 70] of integer; i, s: integer;

    begin

    clrscr;

    writeln ('задан массив:') ;

    randomize;

    for i:=1 to 70 do

    begin

    a[i]:=random (1000) ; {или алгоритм ручного ввода}

    write (a[i]:5) ;

    end;

    for i:=2 to 70 do

    if a[i] mod 2 = a[i-1]mod 2 then

    begin

    s:=a[i]+a[i+1];

    writeln (a[i-1],'+', a[i],'='s) ;

    end;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «дан массив, содержащий 70 неотрицательных целых чисел, не привышающих 1000. Опишите на одном из языков программирования алгоритм, ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Дан массив, содержащий 70 неотрицательных целых чисел, не превышающих 1000. Опишите на одном из языков программирования алгоритм, позволяющий найти и вывести наибольшую сумму двух соседних элементов массива, имеющих различную чётность.
Ответы (1)
Помогите написать программу! Дан целочисленный массив M из 15 элементов. Элементы массива могут принимать целые значения от - 500 до 500 и вводятся с клавиатуры. Найти и вывести: 1. Сумму квадратов отрицательных элементов.
Ответы (1)
Дан массив, содержащий 2014 неотрицательных целых чисел, не превышающих 10 000. Опишите на языке программирования Паскаль алгоритм, позволяющий найти и вывести сумму всех со-держащихся в массиве трёхзначных чисел, десятичная запись которых
Ответы (1)
1. Возвести в квадрат все элементы массива A. Размер массива и значения элементов массива - произвольные. 2. Увеличить на 4 все элементы в первой половине массива A (считать, что в массиве чётное число элементов).
Ответы (1)
Хотя бы 3-4 задачи! 1) Дан одномерный целочисленный массив размерностью N. Найдите количество элементов, которые кратны 3 (5). 2) Дан одномерный целочисленный массив А, состоящий из N элементов. Найти сумму всех четных элементов массива.
Ответы (1)