Задать вопрос
8 февраля, 09:47

Дан массив целых чисел. найти количество элементов массива, значения которых больше заданного числа A и кратных 5

+1
Ответы (2)
  1. 8 февраля, 10:13
    0
    Const n=10;

    var arr:array [1 ... n] of integer;

    a, k, i:integer;

    begin

    Randomize;

    writeln ('Исходный массив:') ;

    for i:=1 to n do

    begin

    arr[i]:=random (51) ;

    write (arr[i]:4) ;

    end;

    writeln;

    write ('a = ') ;

    readln (a) ;

    k:=0;

    for i:=1 to n do

    if (arr[i] > a) and (arr[i] mod 5=0) then k:=k+1;

    writeln ('k = ', k) ;

    end.

    Пример:

    Исходный массив:

    23 25 41 15 3 48 33 24 10 35

    a = 12

    k = 3
  2. 8 февраля, 11:32
    0
    Var b:array [1 ... 100000] of integer;

    a, k, i, n:integer;

    begin

    k:=0; {обнуляем счётчик}

    readln (n) ; {вводим количество элементов в массиве}

    readln (a) ; {задаём число а, с которым потом будем сравнивать}

    for i:=1 to n do{запускаем цикл}

    begin

    if (b[i] > a) and ((b[i] mod 5) = 0) then{проверка на выполнение условий, заданных в задаче}

    k:=k+1; {при выполнении условия, увеличиваем счётчик на один}

    end;

    writeln (k) ; {выводим количество элементов, удовлетворивших условию задачи}

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Дан массив целых чисел. найти количество элементов массива, значения которых больше заданного числа A и кратных 5 ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Помогите решить задачи на паскаль. 1) Дан массив случайных чисел (количество элементов вводите с клавиатуры). Найти произведение всех элементов массива. 2) Дан массив случайных чисел (количество элементов вводите с клавиатуры).
Ответы (1)
Хотя бы 3-4 задачи! 1) Дан одномерный целочисленный массив размерностью N. Найдите количество элементов, которые кратны 3 (5). 2) Дан одномерный целочисленный массив А, состоящий из N элементов. Найти сумму всех четных элементов массива.
Ответы (1)
1) Дан одномерный массив А[N], - целых чисел. Заменить все большие 7 члены массива числом 7. Найти количество таких членов. 2) Задан массив из 10 элементов, найти произведение элементов массива. Задача №3.
Ответы (1)
1. Массив и 4 целых чисел вводится с клавиатуры. Найти и вывести произведение элементов массива. 2. Массив из 6 отрицательных и положительных целых чисел вводится в области описания констант. Найти сумму положительных элементов массива. 3.
Ответы (1)
дан массив из семи элементов написать программу подсчитывающую среднее второго и предпоследнего элементов массива дан целочисленный массив из 10 элементов написать программу находящую сумму элементов массива красных 3 ил 5 дан целочисленный массив
Ответы (1)