Задать вопрос
6 марта, 07:31

написать программу в Pascal: по возрасту, введённому с клавиатуры, определить, к какой возрастной группе относится человек: от 0 до 7 лет дошкольник, от 8 до 17 лет школьник, от 18 до 23 лет студент, 24-55 лет работник, от 56 лет и старше пенсионер.

+1
Ответы (2)
  1. 6 марта, 07:42
    0
    var

    l:integer;

    begin

    writeln ('skolko let?') ;

    readln (l) ;

    if (l>=0) and (l<=7) then

    writeln ('Doshkolnik')

    else if (l>=8) and (l<=17) then

    writeln ('shkolnik')

    else if (l>=18) and (l<=23) then

    writeln ('student')

    else if (l>=24) and (l<=55) then

    writeln ('rabotnik')

    else if l>=56 then

    writeln ('pensioner') ;

    end.
  2. 6 марта, 11:20
    0
    var

    a:integer;

    begin

    write ('Введите возраст ') ; readln (a) ;

    write ('Этот человек ') ;

    case a of

    0 ... 7: writeln ('дошкольник') ;

    8 ... 17: writeln ('школьник') ;

    18 ... 23: writeln ('студент') ;

    24 ... 55: writeln ('работник') ;

    else

    writeln ('пенсионер') ;

    end;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «написать программу в Pascal: по возрасту, введённому с клавиатуры, определить, к какой возрастной группе относится человек: от 0 до 7 лет ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Напишите программу на Pascal, которая по введенному возрасту определяет, к какой возрастной группе относится человек: ребенок или взрослый.
Ответы (1)
Напишите программу, которая анализирует человека по возрасту и относит к одной из четырёх групп: дошкольник, ученик, работник, пенсионер. Pascal
Ответы (1)
Помогите! Составить программу, которая по введенному возрасту пользователя сообщает, к какой возрастной группе он относится: До 13 лет - детство; От 14 до 24 лет - молодость; От 25 до 59 лет - зрелость; От 60 лет - старость.
Ответы (1)
Составить программу, которая по введенному возрасту пользователя сообщает, к какой возрастной группе он относится: До 13 лет - детство; От 14 до 24 лет - молодость; От 25 до 59 лет - зрелость; От 60 лет - старость.
Ответы (1)
По введенному года рождения рассчитать возраст человека и отнести его к одной из 4-х групп: дошкольник, ученик, работник, пенсионер. не могу решить
Ответы (1)