Задать вопрос
17 августа, 10:48

составить программу в паскале для поиска простых чисел в числовом промежутке от 1 до 100

+4
Ответы (1)
  1. 17 августа, 12:48
    0
    program abc;

    var

    i, j:integer;

    pr:boolean;

    begin

    writeln ('Простые числа в диапазоне от 1 до 100: ') ;

    for i : = 2 to 100 do

    begin

    pr : = true;

    for j : = 2 to i div 2 do

    if i mod j = 0 then

    begin

    pr : = false;

    break;

    end;

    if pr then

    write (i, ' ') ;

    end;

    writeln;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «составить программу в паскале для поиска простых чисел в числовом промежутке от 1 до 100 ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Логическое "ИЛИ" называется? 1. логическая связка для поиска всех других слов, кроме указанного в запросе 2. логическая связка для поиска по всем словам 3. логическая связка для поиска по любому из слов Ответ:
Ответы (1)
1. Напишите алгоритм подсчета числа элементов, равных максимальному, в числовом массиве из 30 элементов. 2. Напишите алгоритм поиска трех последовательных элементов, сумма которых максимальна, в числовом массиве из 30 элементов.
Ответы (1)
Результаты поиска для фразы "четверо друзей во время путешествие одалживали друг у друга деньги используя доблицу долгов опредилите кто из ребят во время раздачи долгов получит наибольшую суму" Результаты поиска для фразы "четверо друзей во время
Ответы (1)
Помогите написать программу в паскале! Написать программу в паскале: В одномерном массиве из 10 целых чисел вычислить сумму четных чисел ...
Ответы (1)
Составьте программу в Паскале для поиска: a) суммы положительных элементов массива от а от 1 до 100, введенных с клавиатуры b) произведения отрицательных элементов массива а от 1 до 100 c) количества нулевых элементов массива с сотней элементов
Ответы (1)