Задать вопрос
30 октября, 09:02

С клавиатуры одной строкой вводят имя и фамилию. Составьте программу, которая определяет, есть ли во введенной строке заданный символ

+2
Ответы (1)
  1. 30 октября, 11:16
    0
    var

    slovo, simval:string;

    i, k:integer;

    begin

    k:=0;

    write ('Введите имя и фамилию ') ;

    readln (slovo) ;

    write ('Введите символ ') ;

    readln (simval) ;

    for i:=1 to length (slovo) do

    begin

    if slovo[i]=simval then k:=k+1;

    if slovo[i]=simval then writeln (i,' ') ;

    end;

    if k>=1 then

    writeln ('Да, встречается ', k,' раз, на позиции ', i) else writeln ('Нет') ;

    end.

    Я немножко перевыполнил) От показывает есть симаол или нет, если есть то сколько раз он входит и на какой позиции ...
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «С клавиатуры одной строкой вводят имя и фамилию. Составьте программу, которая определяет, есть ли во введенной строке заданный символ ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы