Задать вопрос
30 января, 21:50

Дан массив А из 20 элементов. Найти сумму элементов массива. Результат вывести на печать.

на языке бейсика. если можно полное решение ...

+3
Ответы (1)
  1. 30 января, 22:12
    0
    program summa;

    uses Crt;

    const

    n = 20;

    var A: array[1 ... n] of integer;

    s: integer;

    i: integer;

    begin

    ClrScr;

    randomize; {запускаем генератор случайных чисел}

    FOR I:=1 to n do

    A[i]:=random (20) ;

    FOR I:=1 to n do

    begin

    Write (A[i]) ;

    Write (' ') ;

    end;

    s:=0;

    FOR I:=1 to n do

    S:=S+A[i];

    WriteLn;

    WriteLn ('Сумма чисел: ', s) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Дан массив А из 20 элементов. Найти сумму элементов массива. Результат вывести на печать. на языке бейсика. если можно полное решение ... ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Хотя бы 3-4 задачи! 1) Дан одномерный целочисленный массив размерностью N. Найдите количество элементов, которые кратны 3 (5). 2) Дан одномерный целочисленный массив А, состоящий из N элементов. Найти сумму всех четных элементов массива.
Ответы (1)
1. Массив и 4 целых чисел вводится с клавиатуры. Найти и вывести произведение элементов массива. 2. Массив из 6 отрицательных и положительных целых чисел вводится в области описания констант. Найти сумму положительных элементов массива. 3.
Ответы (1)
Помогите решить задачи на паскаль. 1) Дан массив случайных чисел (количество элементов вводите с клавиатуры). Найти произведение всех элементов массива. 2) Дан массив случайных чисел (количество элементов вводите с клавиатуры).
Ответы (1)
дан массив из семи элементов написать программу подсчитывающую среднее второго и предпоследнего элементов массива дан целочисленный массив из 10 элементов написать программу находящую сумму элементов массива красных 3 ил 5 дан целочисленный массив
Ответы (1)
1) Дан одномерный массив А[N], - целых чисел. Заменить все большие 7 члены массива числом 7. Найти количество таких членов. 2) Задан массив из 10 элементов, найти произведение элементов массива. Задача №3.
Ответы (1)